No WARP+ when using Firewall Proxy in Teams

Hi there!

Whenever I enable Firewall Proxy in Teams, the clients no longer get Warp+ and instead just gets Warp. If I disable Proxy I can no longer access my warp tunnels which I require. Is this intended behaviour? Is there a way for me to keep Warp+ and still have access to my warp tunnels?

Thank you.