No SSL certificate

Hi,

I’ve recently setup my site: websterly.com. It’s hosted with namecheap and the domain is registered by GoDaddy. I went to Cloudflare to get my website to https instead of http. I followed all the steps and put the encryption mode to “full (strict)”. Now when I try to acces the site, it is an https, but my antivirus software doesn’t let me through. It says that the connection isn’t protected, because the certificate is invalid.

How can I fix this? I’ve already tried to put the SSL encryption mode to full and off. I even removed the whole website from Cloudflare and re-registered it, but nothing helps.

Thanks in advance for your help!

By configuring your server with a proper SSL certificate.

The encryption mode should be either “Full strict” or “Off”, with the former being required if you need SSL.

Right now you don’t have any DNS records on Cloudflare, so it won’t work in the first place and you seem to have a DNS propagation issue, however that very issue points out that your server is insecure.

Best thing at this point

  • Pause Cloudflare so that nothing is proxied.
  • Add the necessary DNS records.
  • Make sure your site loads fine on HTTPS.
  • Unpause Cloudflare only once it all worked.
2 Likes

Thank you so much! I’ve added the DNS records. Then I got an error 526, for an invalid SSL certificate. On this forum post, they said I should change the Full (Strict) to Full. Since I’ve done that, everything works fine!

If it is not Full strict it is not really secure. You need to fix your server certificate and change that back to Full strict. Right now it is insecure as it does not validate the certificate.

1 Like

How do I get a SSL certificate?

Your host should provide that to you. If they don’t you can either get an Origin certificate from Cloudflare or this.

1 Like

I’ve installed the origin certificate, everything works still fine in my normal browser. But when I go to incognito mode or another browser, I get a message from my antivirus that the certificate chain is not complete. I gave the origin sertificate and private key in in the EasyWP SSL setup.

Your site loads fine right now

image

That seems to be the message from before. Either you still have a propagation issue or you are not connecting via Cloudflare but directly to your server and as Origin certificates are only trusted by Cloudflare your browser might show that warning.

1 Like

I am sorry but this is rather bad advice and the OP should definitely not follow it.

What you just recommended it an insecure setup and would have removed all encryption from the OP’s site and was actually even addressed already here.

1 Like

Thank you for your help, I think it was a propagation issue that persisted yesterday. I haven’t done anything since my last post and now it all works perfectly. Thank you @sandro!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.