No solution works for "Failed to lookup registrar"

Failed to lookup registrar and hosting information of ***** at this time. Please contact Cloudflare Support or try again later.
I tried the solutions in the following link but it didn’t work

I tried to open tickets but it closed automatically by Cloudflare bot.

That domain is probably registered under a TLD which is governed by the Freenom registry. Freenom currently experiences issues with their Whois service which prevents such domains from being added to Cloudflare. Freenom needs to fix that on their side. Unfortunately there is no ETA known for that.

It probably is best to register a proper domain instead. They already go for less than $10 a year.

This makes sense.
This happens with multiple Freenom domains.
Didn’t have this issue in the past.
I couldn’t find the information you provided in the forum.
Thank you so much.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.