No padlock mobile

Can someone help me with this security issue I’m experiencing on mobile? I have check for mixed content and that my certificate is implemented correctly. But for some reason, only on mobile google chrome from what I can tell, it’s showing insecure in the address bar.

I checked the website and wasn’t able to replicate the issue, your phone might have a cached version where you didn’t have a proper HTTPS implementation.

You have a few images which are attempting to load over HTTP

Chrome and Firefox auto-upgrade these requests to HTTPS. I’m guessing Safari doesn’t, or you’re using too old a version.

You can change them in the source of your website to simply load over https (change http:// to https://), or you can try enabling Automatic HTTPS Rewrites. You can find Automatic HTTP Rewrites under your website in the dashboard, and then SSL/TLS → Edge Certificates → scroll down to Automatic HTTPS Rewrites and enable, or via this Magic Link:

It looks like some of them are loading from CSS, which Automatic HTTP Rewrites won’t fix, and you’ll have to change them manually.


That resolved my issue. I ended up using the Better Search plug-in to find those instances of HTTP and replace them with the https version. thanks!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.