No option to support users behind NAT in rate limiting advanced criteria

Answer these questions to help the Community help you with Security questions.

What is the domain name?
rownd.io

Have you searched for an answer?
Yes

Please share your search results url:
I can’t post links

When you tested your domain using the what were the results?
Everything looks fine

Describe the issue you are having:
When setting up Rate Limiting, I do not see the NAT toggle to “support users behind a NAT”. This shows up in the documentation for configuring rate limiting. Our domain is on the Enterprise plan, so that shouldn’t be a problem. (I’d share links here, but apparently that’s forbidden)

As a side note, it also doesn’t look like we have all of the options granted to the Enterprise plan for “action duration” and “request period” listed in the documentation here. The dropdowns look limited (perhaps this is related?):

What steps have you taken to resolve the issue?

  1. Tried in another domain that we own and is managed by CF
  2. Looked for news about this feature being moved / removed
  3. Looked for other ways to enable it

Here’s a screenshot of the missing NAT toggle:

Unfortunately IP with NAT support and the other mentioned features are only available with Enterprise Advanced Rate Limiting (it’s a seperate thing from normal Enterprise) per the feature table here: Rate limiting rules · Cloudflare Web Application Firewall (WAF) docs

If you need to upgrade your Enterprise account to Advanced Rate Limiting I’d reach out to your Enterprise CSM :slightly_smiling_face:

Ah ok. Bummer. I missed the “Advanced” suffix on the plan and in my mind tied that into the Advanced Criteria section in the rate limiting configuration modal. Thanks @mcfadyeni

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.