No MX records are propagated in China

Hi, since I moved my DNS to Cloudflare I’m not receiving emails from China. After contacting my hosting provider they confirmed the issue is with No MX records are propagated in China. Can you please help me to fix that asap? Thank you


Thank you for asking.

I am sorry to hear you are experiencing an issue with receiving and/or sending e-mails while using Coudflare for your domain name.

May I ask you to post and share the URL example to the particular resource in a bracketed dot [.] notation with us so we could double-check, troubleshoot and provide some feedback information? :thinking:

Usually, the MX record should point to a hostname such as mail , and the A (or CNAME ) type record for that hostname should be set to :grey: (DNS Only).

Have you tried using any of the available online tools for DNS propagation check for your domain name yet? For example:

Furthermore, if you recently changed your domain nameservers, regular DNS propagation time usually takes up to 24-48 hours to complete.

Since you recently moved your domain to your Cloudflare account, I could try to troubleshoot at first sight without knowing anything other as it could be related to either:

  1. Wrongly setup e-mail related DNS records at the DNS tab of Cloudflare dashboard for your domain name
  2. Possibly missing some TXT /CNAME records (for SPF , DKIM, DMARC if so?)
  3. You are using a hostname like which is :orange: (proxied) rather than the unproxied :grey: (DNS-only) like (possible this one not existing or is :orange: instead of being :grey:) at the DNS tab of Cloudflare dashboard, in your e-mail client for sending/receiving server (MS Outlook, Mozilla Thunderbird, etc.)

May I suggest checking below article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:

1 Like

thank you fritex for your prompt response. In fact I tried and this is result: [link](

is there any response please? from our side everything is set correctly, I’ve doubled-checked with the hosting provider

Thanks for providing the domain name,

Do you have an example of a DNS resolver in China that is not updating? Maybe it takes an additional day for changes to propagate if there was a long TTL set.

This suggest it is all matching globally including China. DNS Checker - DNS Check Propagation Tool DNS Checker - DNS Check Propagation Tool

@fritex has some excellent advice above on what else to check besides a missing MX record. Unfortunately, the way DNS works once you make a change there is nothing you can do to speed up the global propagation (You have to wait until the TTL expires). The speed can only be adjusted ahead of time by lowering the TTL (and you have to wait for the previous TTL to expire for this change to propagate as well).

no I don’t have any example currently, some emails are received and some not. For those that are not when I resend them to my gmail there are received immediately

another email no received from this email address “[email protected]”. When sent to gmail account, received immediately! Can you please investigate further?

can I have a resolution on this please?

Microsoft’s MX records don’t resolve with this tool either. It’s more likely this is a tool issue than an actual issue with DNS.

can you elaborate further? what tool issue?

Assuming you Mx records are correct in DNS you would need to talk to your mail host or the sender directly about delivery issues.

The “tool issue” simply refers to the fact that there are ongoing issues with the website and/or at least one of it’s test locations.

You can repeat your MX test over and over on, and Beijing, China (CNNIC) will literally flap around with the results, for example first by claiming that the MX record lookup have failed, and if you then test it again, you could be lucky that Beijing, China (CNNIC) would now say that the expected MX records were successfully found.

In fact, I have just tested with your domain, 5 times Beijing, China (CNNIC) failed the lookup. On the 6th test, it did in fact respond with the proper MX records as (many) other locations did…

That stuff solely indicate that there are either issues with the Beijing, China (CNNIC) location that the tool use, or the connection between the site and the Beijing, China (CNNIC) location is broken, or something similar to that, - which means the issue is on the’s side to fix, and not on Cloudflare’s side to fix…

It does not mean that there are “No MX records are propagated in China”, as you indicated with your thread title

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.