No longer receiving emails from gmail.com etc. [DNS Issue]

Hi all,
I just switched from my old provider to cloudflare’s nameservers. I copied all DNS entries from my old provider to cloudflare, but since then I am no longer able to receive emails send via gmail.com to my inbox (redacted)

Settings:

Can anybody help me? What is wrong there?

you are no hosting email at gmail (Gsuite - now called Google Workspace at all).
Change your PRIMARY MX record on cloudflare to aspmx.l.google.com and priority 1
If you want, you can set up up to 4 MX records

You just change your current MX records at mail.***.de and change it to aspmx.l.google.com then change priority from 10 to 1.
Add more 3 others MX records as below:

Values for Google Workspace MX records

Name/Host/Alias Time to Live (TTL*) Record Type Priority Value/Answer/Destination
@ or leave blank 3600 MX 1 ASPMX.L.GOOGLE.COM
@ or leave blank 3600 MX 5 ALT1.ASPMX.L.GOOGLE.COM
@ or leave blank 3600 MX 5 ALT2.ASPMX.L.GOOGLE.COM
@ or leave blank 3600 MX 10 ALT3.ASPMX.L.GOOGLE.COM
@ or leave blank 3600 MX 10 ALT4.ASPMX.L.GOOGLE.COM

Disable proxy for mail-related DNS records.

Hi,

1.) I do not want googlemail as mail service, I just can not receive emails from a .googlemail.com - email address.

So that means I am unable to receive emails unless I turn off proxy for my domain which was the main reason for switching to cloudflare - to protect my domain from ddos …

Are you receiving any email?

As @erictung mentioned, only that ‘mail’ hostname needs to be set to :grey: (DNS Only), as Cloudflare does not proxy email connections. If that ‘mail’ hostname is one of those CNAME records, make it an “A” record instead and use your mail server’s IP address.

1 Like

Hi,
these 2 define the mail setting:

and both already are set to “only DNS”

So what else can I do?

Should I delete the MX record and instead add something like this:

A - mail - 123.123.123.123 - only dns ? would this work? my mail server is “mail.mydomain.de

Those aren’t the problem. You’ve hidden so much of your DNS screen that we can’t troubleshoot, other than what we’ve already suggested.

1, Sorry for misunderstanding. You mean you cannot receive email from other email system like gmail, right?
May be it’s because you have just change dns and Registrar system not updated.
2, cname record for mail.yourdomain. don’t effect to email system, email system depend on MX records for email hosting. So if you change MX record exact as hosting provider provide, it should work as soon as nameserver updated.

All the hidden entries are not related to email.
So basically the current settings are:

A - mydomain.de - 123.123.123.123 - Auto - Proxy Enabled
MX - mydomain.de - mail.mydomain.de - 10 - Auto - Proxy Disabled
TXT - mydomain.de - v=spf1 mx ip4:123.123.123.123 -all - Auto - Proxy Disabled

And I do receive emails from some providers like gmx.net just fine. Only from googlemail.com I am unable to receive any emails.

I made these changes more than 48 hours ago.

Googlemail error is:
DNS Error: 20418443 DNS type ‘mx’ lookup of mydomain.de responded with code NOERROR 20418443 DNS type ‘aaaa’ lookup of mail.mydomain.de. responded with code NXDOMAIN 20418443 DNS type ‘a’ lookup of mail.mydomain.de. responded with code NXDOMAIN

Check your MX record to see if it’s updated all over the world.
Replace google.com by your domain.

Then you’ve got a serious problem. Your MX record points to a non-existent hostname.

1 Like

it is updated worldwide

What do you mean with non existent hostname? mydomain.de ? The website is working just fine.
And I do receive some emails, but not from all providers. I can also send emails from mydomain.de

you are point cname mail.yourdomain. to ip address same as ip of yourdomain.?
If it true, then check if mail.yourdomain is set to proxied on (orange icon)? In this situation, you have to set cname mail.yourodmain to grey icon (not use proxy) and it mean it’s explode your server ip.

The CNAME records do not have anything to do with mail. these are my CNAME records (little bit altered for security reason):


Or maybe I did not understand what you saying?
Both, mail and webserver are on the same IP

You have an MX record that tells the world that mail to someone @mydomain.de should be sent to mail.mydomain.de. According to you, you don’t have an “A” or “CNAME” record for ‘mail’. So mail can’t be delivered to your domain.

Just for test purpose, creating a cname like abc.yourdomain point to server ip no proxied (grey icon),
Then delete all MX records and create new MX record for yourdomain point to abc.yourdomain

Both, mail and webserver are on the same IP

It should work.

1 Like

Here are the full dns settings (I only changed IP Adresses and domain names - search & replace):


Maybe it’s easier to find the issue now?

if email hosting on same server as your web hosting (in this case is 10.10.10.10), then change your mx record to mydomain.de instead of mail.mydomain.de

And make sure mydomain.de do not use proxied (orange icon)

As I already stated:

1 Like