No longer able to update DNS records via API

Still not working. 1:20pm PST

The issue is not resolved. Still getting the same errors.

Please re-open.

Can you let Support know and they can investigate? To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help from the bottom of the page.

Edit - Are you seeing 502 errors?

I still can’t update my DNS with the API, I get the following error: “error”: “Use of this API has been limited to the Cloudflare Dashboard.”

1 Like

Thank you, do you have a ticket with Support? If, can you share the ticket number here? Sorry for the issues.

Hi I’m new here. I have no ticket.
I see that there are several with my same situation and they have not been able to update either.
Should I open a ticker for my situation?

Hi @lidemar2004, welcome & sorry for the troubles. If you open a ticket, that’ll help Support know how big the issue is and give them another opportunity to troubleshoot. Alternatively, I’ll update the issue here as I see progress and you can track it here.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help.

I opened a ticket about this YESTERDAY. Incident Number 1818793

I have had ZERO response from CloudFlare. All i have seen is the pages here that keep saying it is resolved, and it is still not working.

I’m getting 401 errors:

“error”: “Use of this API has been limited to the Cloudflare Dashboard.”

Thank you, I see your ticket and the additional details you added, I’ve cc’d myself and added a link to this conversation.

Hi @msl0000023508, can you try that without the trailing slash /?

The team is aware of this issue and it’s affect on certain free TLD. if you’re impacted by this, please manage these records via the dash as opposed to via the API.

Then why does the status still say resolved, when it obviously isn’t, for me and for many others?

And i need to use the API, not the dashboard. this is being done through Terraform.

Still not able to edit DNS record.

requests.put(
    f"{CLOUDFLARE_API}/zones/{ZONE_ID}/dns_records/{DNS_ID}",
    headers=auth_headers,
    json=dns,
).json()

returns {'code': 1001, 'error': 'method_not_allowed'}. same for patch

The issues with the API that affected the Analytics API, GraphQL API, Zone Analytics API and Firewall Events API was resolved and the fix is being monitored.

The issue with managing DNS records via API is a different issue.

Rock stable Script failed today, I had to add TTL which I had not done before.
my curl looks like this now:
curl -s -X PUT “https://api.cloudflare.com/client/v4/zones/$zone_identifier/dns_records/$recordAAAA_identifier” -H “X-Auth-Email: $auth_email” -H “X-Auth-Key: $auth_key” -H “Content-Type: application/json” --data “{“id”:”$zone_identifier",“type”:“AAAA”,“name”:"$record_name",“content”:"$ipSix",“ttl”:120}"

Same problem here, PUT is not working. I’m getting this response:
{
“result”: null,
“success”: false,
“errors”: [
{
“code”: 1000,
“message”: “There was an unknown error.”
}
],
“messages”:
}

Same here. My Mikrotik script for Dynamic DNS IP Update also suddenly stopped working 2 days ago.
Last successful API call: January 21st 12:00am GMT+8. Until now still not working.

*1 day ago
When I run the script manually in the Mikrotik RouterOS terminal, I get a Error 400: Bad Request response.

Trying PATCH without ending / in URL gives me 401 Unauthorized

wget --inet4-only --header "Authorization: Bearer x" --header "Content-Type: application/json" --method PATCH https://api.cloudflare.com/client/v4/zones/x/dns_records/x --body-data '{"type":"A","content":"x","proxied":false}' --content-on-error --output-document -  
--2020-01-22 02:16:26--  https://api.cloudflare.com/client/v4/zones/x/dns_records/x
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving api.cloudflare.com (api.cloudflare.com)... 104.19.192.29, 104.19.193.29
Connecting to api.cloudflare.com (api.cloudflare.com)|104.19.192.29|:443... connected.
HTTP request sent, awaiting response... 401 Unauthorized

Username/Password Authentication Failed.

PUT fails as same.

1 Like