No Image-Resize enabled in Pro Plan

I’ve upgraded to Pro-Plan and enabled Image-Resizing, but there is no resizing header in the response no matter what URL I try. Here is an example:

curl "https://weg.li/cdn-cgi/image/width=100/assets/phoet-0e9dc2665477779a975ffe101e201972408ae37ae45094372286d4370d226237.jpg" -I

HTTP/2 404
date: Wed, 12 Jan 2022 20:06:10 GMT
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
server: cloudflare
cf-ray: 6cc900fbd88c4522-TXL
alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400, h3-28=":443"; ma=86400, h3-27=":443"; ma=86400

Did you follow this https://developers.cloudflare.com/images/image-resizing/enable-image-resizing and enabled Image Resizing before testing it?

1 Like

It is enabled as stated in the docs.
I’ve also tried with developer mode enabled and after flushing the cache.

Do you have any worker route activated that would match the given image and therefore block the resize?

To check if anything interferes with Image Resize please have a read here: https://support.cloudflare.com/hc/en-us/articles/4412024022029-Troubleshoot-Image-Resizing-problems

There are no workers or page-rules configured

Please post a full screenshot of this section of your Dashboard:

For me it seems this is not activated for your ZONE. Also since this is a usage based product, make sure you have some valid Payment information provided to Cloudflare in the Billing section.

The 404 you get when calling a URL which should be processed by Image Resizing is a clear indicator for not having it activated.

well, as I said, it IS ACTIVATED

Thanks Peter, I will forward this to the devs. Seems like there is something not working properly.

Could you do me a favour and deactivate it, then activate it again?

Thanks.

Sure, I’ve tried, but nothing has changed, there is still no header indicating any resizing activity.

If you talk to any devs, i’ve noticed that the new cloudflare dashboard crashes firefox on macos monterey reliably on every hard refresh.

This would be a separate issue, but will append it.

I had this issue also but on a fresh install I cannot reproduce it so I think it’s a conflict with some Firefox setting. Haven’t figured out what yet.

2 Likes

Images are served from some bucket or uploaded using Cloudflare Images?

Why do I see IP 216.x.x.x …

While writing I found out it’s proxied server: cloudflare and:

  • www.weg.li -> weg-li.onrender.com -> weg-li.onrender.com.cdn.cloudflare.net -> [ 216.x.x.x 216.x.x.x ]

Nevermind, I am just thinking …

1 Like

Can you please open a support ticket and post the ticket number here? :slight_smile:

@user18627 Hello Peter, may i ask you to create a ticket by writing an email to support [at] cloudflare.com and providing us with the ticket number?

Thanks in advance!

1 Like

I had this issue also but on a fresh install I cannot reproduce it so I think it’s a conflict with some Firefox setting. Haven’t figured out what yet.

@domjh Looks like a Firefox issue with http3 https://twitter.com/jbaiter_/status/1481543050438619139

@fritex you were on the correct path.

The image-resizing did not happen because DNS proxy-mode was disabled on the domain. This is a recommendation of render.com because they themselves use cloudflare. So the response-header was actually a red-herring, indicating a render.com cloudflare account where image-resizing is not enabled.

Since enabling proxy-mode on the root domain is not recommended with the render.com setup, i added a new sub-domain with proxy-mode to serve images from.

1 Like

Have you created a ticket yet and can you share the ticket number here, so we can follow up, or is the changed setup working for you as intended? @user18627

2 Likes

The ticket is #2348989

jochen’s shift has ended, but I’ve added your ticket to the escalation queue.

1 Like