No HTTPS and Emails not being received

URL: http://thailandgolfmemberships.com/

I have changed DNS settings as required:

ns1.livedns to jonah.ns.Cloudflare
ns2.livedns to wanda.ns.Cloudflare

ns3.livedns removed.

Now, not only no SSL, but emails no longer being received.

Any ideas please how to correct before I return to previous settings?

Hi

Complete newbie here, but I experienced these issues when setting up yesterday. I also lost incoming mail - remedied by setting up 2 new MX Records in Cloudflare DNS section, pointing at the same 2 mailserver addresses as were being used by my original mail provider. Incoming mail now works again - but may not be being routed via Cloudflare…

I’m also hoping to sort out my Https and SSL status, using Universal SSL (Flexible) but nothing seems to have changed yet (still waiting for full 24 hours to expire though) - if you learn anything helpful on this please post here…?

atb

Jon

1 Like

Thanks Jon.

Also a newbie.

I do not have any MX record and I suppose I could try that. I am not sure what address(es) to add since there was no MX record before.

This Cloudflare process seems to be far from straightforward!

Neville

1 Like

I’m successfully set up on it now, happy to offer some suggestions on a strictly ‘no liability’ basis of course!

First thing is to get your current mailserver names from your mail provider and create new MX records with these within Cloudflare. This will sort your incoming mail.problem

1 Like

Thank you for your help.

I have requested the mailserver names from my hosting service.

1 Like

No problem. Other steps for successful SSL and HTTPS config for me were, under SSL/TLS app, i) setting SSL type to Flexible and ii) setting to “HTTPS always on” - but if you want to use your own SSL certificate you may need to do different.

Good luck!

1 Like

Thanks again for your help. I do not know what the SSL/TLS app is?

My hosting service is Fasthosts UK.

This is what I got back from their Support when I asked about Mailserver names:

" Thank you for your recent enquiry (180810-000819).

_ What do you mean by mailserver names?_

_ What are you trying to achieve, please?_

_ Are you trying to point the MX Records to us?_

_ Fasthosts MX Records details:_

_ mailserver.domainname_

213.171.216.40

priority 10

_ I await your response, thank you._ "

MX Record now shows as pointing to mailserver.domainname but emails still not being received.

Neville

1 Like

Hi, I’m sorry, I’ve been away. Did you get this sorted?

Yes, finally (with a little help from the hosting service, Fasthosts).

Thanks for all your help.

Best regards.

Neville

1 Like

Very pleased to hear, sorry again about disappearing on you. One thing - I found that our site traffic dropped alarmingly when I switched on ‘Always use https’ - so do NOT use this unless your hosting service advised you to.

atb

The hosting company advise keep it ON

Really…? Did they say why?

“With regard to your case for your website, https should be ON so that your site will be secured.”

Thanks, understood and appreciated!

atb

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.