No funciona Cache ClouFlare


#1

Hola amigos, a ver si pueden ayudarme. Tengo mi web en un servidor gratuito un poco lento, utilizo el sistema cloudflare para poner https a mi pagina. He estado indagando un poco mas en los servicios de CloudFlare y es FANTASTICO!

El tema es que tengo activada la opción de cache pero se que no debe estar funcionando porque mi servidor se cae cada 2 por 3 y realmente deja de funcionar. He leído en algún post ingles algo de activar una regla? Mi web es estática y eta echa con wordpress.

¿Como creo esa regla o hago funcionar el cache? Teniendo en cuenta que a primera vista ya esta activado y la opción “siempre online”

Gracias y un saludo!!


#2

Hola Ruben, cómo estás? Veo que estás bastante confundido de cómo funciona CloudFlare y su implementación. Como dices, es una herramienta fantástica, pero MUY amplia, y con sólo activarlo no solucionas tu problema.

En primer lugar, si tu web es estática, es HTML puro; si esta echa con wordpress, es dinámica (PHP y MySQL), para que lo tengas en cuenta. Eso no es problema, de todas formas, sólo una aclaración. WordPress facilita la vida y administración de contenidos, generar una web a razón de pocos click, PERO consume muchos recursos, y cuando tienes algunas pocas visitas o algún proceso/actualización, se caerá en cualquier servicio gratuito.

En primer lugar consideraría buscar otro web-hosting, hay algunos MUY económicos, pero que alcanzan para tener activo el sitio y crecer, sin caídas.

Respecto de la regla, puedes “cachear TODO el HTML” (en sentido figurado, recordemos que WordPress lo genera dinámicamente, pero ayuda bastante este filtro), sólo deberás ir a REGLAS y aplicar esta configuración: https://support.cloudflare.com/hc/en-us/articles/115000150272-How-do-I-use-Cache-Everything-with-Cloudflare-

Pones tu dominio.com/* (barra y astericso), así TODO lo que esté detrás de eso se pasa por la regla “caché everything”.

Luego generas OTRA regla dominio.com/wp-admin/* (también con asterisco al final de la barra), y a esta le pones “cache bypass”, también seleccionas “disable perfomance” y le pones en “order/priority FIRST”.

Debe quedar luego esta regla arriba de la otra, así puedes acceder al panel de administración SIN cache, y también activa el plugin de CloudFlare, para que sea más ágil.

Ten en cuenta que WordPRess tiene procesos CRON, que son tareas rutinarias que revisan si hay actualización, si hay post programados, etc; estas son necesarias y cuando se ejecutan consumen bastante memoria, lo que en un servicio gratuito está bastante limitado. También afecta el tipo de theme usado, con este caché que indico AYUDA, pero no es una solución definitiva. Los plugins facilitan la vida, pero son bastante pesados para tu servidor actual, considera quitar todos los que no necesites al 100%.

Espero te sea de ayuda, recuerdo mis comienzos con WordPress hace ya 10 años y me da nostalgia. Suerte!