No emails when adding CNAME

Can anyone help me here please?

I wanted to verify my domain so that my domain could be used by

To do so I added the three suggested CNAME entries. As a result all my regular emails stopped coming from my domain. I then removed the domainkey entries but still no emails.

If I pause Cloudflare, then they come through OK.

Any ideas please?

That sounds unrelated, as the Sendgrid CNAME entries should not affect your main domain. What’s the domain? (presently I’ve paused Cloudflare so I can get emails)


Your MX record looks like it points to a hostname you have set to :orange:.

Thank you so much for that – but unfortunately that hasn’t solved the problem.

It seems to be this way:

  • I can SEND email from that domain
  • Emails are received at the server
  • Outlook times out when trying to download them from that domain.
  • Has worked flawlessly for a number of years - only when I tried to add and then delete these domainkeys the problems arose.

Is it possible to send screenshots to you from (a) Cloudflare and (b) my cPanel to identify the problem? Would really appreciate it


Your MX record is still pointing to a hostname that’s set to :orange:. This is a strong indication that your DNS is not properly set up for email. Go ahead and post a screenshot of your Cloudflare DNS screen. It’s ok to black out IP addresses.

Thanks my friend

In your Cloudflare DNS:

  1. Delete that second MX record
  2. Delete the “mail” CNAME
  3. Add an “A” record for “mail” with the IP address of your website. Make sure it’s set to :grey:

Thanks again.

Did that.

Emails go to server but then time out on Outlook 365.

When I go back to pausing Cloudflare they come through OK.

Make sure Outlook is configured to use for receiving and sending email.

Absolutely. Always has been :blush:

And works fine when Cloudflare not connected – and has worked with Cloudflare for years until I started messing with the sendgrid settings :frowning:


I see you have a webmail interface. Have you tried that for sending/receiving email?

I’m not clear on what this means. Inbound, or outbound emails? And how do you know they get to the server?

On that TXT record for the SPF, there’s a +a. Can you add a +mx right after that as well?

Solved it!

It appears that the A record for mail was proxied to Cloudflare. Once I changed it to DNS only everything seemed to work.

I hope that was the solution!!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.