No emails from my contact forms

dash-dns
#1

Hi All,
I managed to run my WordPress website though Cloudflare and this woks fine / fast. I only encountered a big problem which is my contact forms (WPCF7 - 5 in total) on the page do not send anymore. After filling in all fields end end send it shows a spinning wheel forever until it shows a message it ‘can’t send the mail’.

My mail server was on my domain and therefor I took a free account at Zoho. The Zoho account was setup and I followed the complete instructions from Zoho for my DNS settings in CF. I double checked every thing but still no success on sending mails (forms) from my page. ( email sent from other email addresses work fine by the way)

Below a picture from my CF DNS settings. Can anybody check if they see some conflicts? If settings are correct any idea what the issue could be and what I can do to solve the issue?

#2

Hi @marc10,

If you pause Cloudflare, under Advanced Actions, on the overview tab,

image

Does the form then work correctly?

Can you also post a screenshot of the error you get from the form (or post the link so we can try it ourselves)?

#3

The page url is product2u.nl
1st button and last button are 2 of the ones connected to a WPCF7 form. They all worked before Cloudflare setup.

I will pause CF in a few minutes and see what happens btw

1 Like
#4

After pausing

failed%20to%20send

#5

I tried it before and got the same message. Given that it doesn’t work with Cloudflare paused, it doesn’t appear to be an issue with Cloudflare services.

Sounds like it may be an issue with your CF7 config. Have you checked the tags and that the mail is set up correctly?

#6

I will check CF7 config but should I change something there when is just changed to Cloudflare? It worked before…
Two hours ago or so I tried to send an test email on MX toolbox and got this result below.
Is the “No PTR Record found” maybe an issue?

#7

You shouldn’t need to. With my setup, CF7 works fine on my website with Cloudflare.