No "Edit" button under action. Trying to delete/add DNS records

No “Edit” button under action. Trying to delete/add DNS records

As stated above, in my account, I do not have anything under the “Action” column. I’m trying to add/delete DNS records and can’t delete a row. Sent this question to Cloudflare support and was told I needed to upgrade.
WAIT… to change a record?

Is that right??

The help directions say,

Edit DNS records

​​Using the dashboard

To edit DNS records in the dashboard:

  1. Log in to the Cloudflare dashboardOpen external link and select an account and domain.
  2. Go to DNS .
  3. On a specific record, click Edit .
  4. Make any necessary changes.
  5. Click Save .

But YET, there is no Edit available.

Delete DNS Record permission needed: #dns_records:edit

  • FREE
  • PRO
  • BUSINESS
  • ENTERPRISE

DELETE zones/:zone_identifier/dns_records/:identifier

cURL (example)

curl -X DELETE “https://api.cloudflare.com/client/v4/zones/023e105f4ecef8ad9ca31a8372d0c353/dns_records/372e67954025e0ba6aaa6d586b9e0b59” \ -H “X-Auth-Email: [email protected]” \ -H “X-Auth-Key: c2547eb745079dac9320b638f5e225cf483cc5cfdda41” \ -H “Content-Type: application/json”

Response (example)

The Delete option is available to “Free” …also found in the help

Kindly, may I ask you to share your ticket number so I could escalate this?

What is your domain name?

Recently another person reported this Issue

2 Likes

Just to follow up on this @bob6272, are you still seeing the issue?

1 Like

Yes I am still seeing this problem , thanks for checking into it

Yes, it was #2377956, thanks for your help. I can’t receive emails to my business site

Can you please try in a private window and if that doesn’t work, a different browser altogether?

Let us know if that does/doesn’t work and that will determine next steps.

I tried in incognito, no change. tried on my iphone, and edit was available. Thanks so much!!
Bob

That is strange, glad you’ve been able to edit them for now but we should still fogure out the original issue if it also did not work in incognito. I presume from that you are using Chrome?

Can you gather a HAR of the DNS page with the broken records and attach it to the ticket you submitted, if you haven’t already?

https://support.cloudflare.com/hc/en-us/articles/203118044-Gathering-information-for-troubleshooting-sites#h_8c9c815c-0933-49c0-ac00-b700700efce7

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.