No Edge Certificates on Website

One website in our account (paulwilliamsongolf.com) no longer has any edge certificate and nobody can now reach the website.

The site has been working fine without any issues for the past year and we have NOT made any changes on Cloudflare.

However today we noticed that the site was returning an SSL error and we noticed that under SSL/TLS > Edge certificates it says “No certificate” ???

It looks like this:

We tried to delete the site on Cloudflare and then re-create it to see if a new certificate was going to be issued. So far nothing.

Our settings on the edge certificate page are:
Always Use HTTPS > OFF
HTTP Strict Transport Security (HSTS) > not enabled
Minimum TLS Version > TLS 1.0
Opportunistic Encryption > ON
TLS 1.3 > ON
Automatic HTTPS Rewrites > ON
Certificate Transparency Monitoring > OFF
Disable Universal SSL > It is NOT disabled

Note: after re-creating the website we noticed that somehow the Disable Universal SSL was actually disabled. This is NOT something we have done.

We have now re-enabled the Universal SSL however there is still no Edge certificate on that domain.

This has been done more than an hour ago before creating this ticket…

Can someone at Cloudflare issue the new certificate asap and look into why the previous one was deleted as well as why the universal ssl was disabled. @MoreHelp

We tried to create a request on help center but we are on the free plan so we need to instead submit a ticket here…

Thank you for your assistance with this

You could try changing certificate authority. That usually solves issues with missing/stuck edge certificates.

2 Likes

Thanks That worked!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.