No customer service response!

I am at a loss here – I am getting no response to my help ticket I submitted more than 8 days ago and I even upgraded from a free account to a paying account – made no difference. CloudFlare is not relying to any communications I send and I am at a loss. I don’t know that I have ever been this frustrated by a lack of customer service by a company. Anyone have any recommendations?

1 Like

All requests get a response, though initially automated. Can you post the ticket # here?

1 Like

Yes, immediately got a standard reply and then got an email asking for more information — the same information I had already given in the initial request. Since then, I have heard nothing and this was over a week ago.

#1998437

What happen when you remove the trailing ) from the destination url in your page rules? I see a checkout page.

Ah, I just attempted to recreate in my account. The trailing ) you see is in the page rules url description list, if you edit, it’s not in the rule itself.

Can you share a copy of your DNS records? Omit/blur the destination ip of your A record and anything else you’d rather not share.

2 Likes

I can’t remove it — if I go into edit it and remove it, once I save it and get out of it — it’s still there. I have even tried deleting and re-entering the information, still puts the ) at the end.

I don’t have access to your ticket, so I don’t know the initial problem, but if you see a ) in the Page Rules list, it would look like mine:

You can test the actual forwarding URL by using curl and looking at the Location: header.
curl -I https://example.com

1 Like

You are talking a little over my head here! :wink: I am definitely not as skilled as you about this. But, here is the problem — their system is putting a closed parentheses at the end of all of my forward domains and there is not open parentheses (nor should be there) — when I take off the ), it works so it is clear that the ) is the problem. When I edit or even delete and re-enter everything with out the ), the system puts it back. You will see from my screenshot that all of my forwards have this and none of them work.

Can you click on the wrench next to the first page rule and share a screen shot of the rule?

I was able to successfully hit your destination page earlier but am seeing the 404 now and via the curl.

1 Like

1 Like

Thank you. The trailing ) is for display purposes, it’s not part of the rule and not related to why it’s failing.

I checked the site against our diagnostics tool and see there are a number of errors with dns records, certificates and redirect loops, https://www.cloudflare.com/welcome-center/health-check/. One of those errors is the issue. But, I’m just not sure which one is causing the rules to not function.

Digging further…

1 Like

Can you check your DNS page? A picture of it would be nice. If there are IP addresses, it’s ok to black them out.

I want to see how the record for ‘www’ is set. While you’re at it, can you verify that the name servers listed farther down on the DNS page are Lex and Robin?

2 Likes

You all are so generous with your time — THANK YOU! I am attaching my DNS page with you…

That looks good to me. I only have a few ideas left.

  1. Can you add a DNS entry, “A” record, for @ (dignityu.com), with an IP address of 192.0.2.1, and make sure it’s set to :orange:.
  2. Edit the Page Rule for sigmakappa and remove the “www.” so the Match is just: dignityu.com/sigmakappa with the same redirect to the offers link.

I want to see if somehow Heroku is overriding Cloudflare, and if that page rule actually works.

Done — and doesn’t seem to have solved anything.

It seems like your page rules are completely ignored. Maybe @cloonan can escalate this.

1 Like

Thanks so much! And, this was totally out of the blue — I didn’t mess with any settings at all and it was working on Sunday and then come Monday, it’s wasn’t.

2 Likes

This seems to now be fixed and I don’t know how or who fixed it but THANK YOU — THANK YOU — THANK YOU!!!

2 Likes

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.