No CNAME are published anymore!

Hello!

I have added some CNAME today and wanted to check for them - now I see, that no CNAME at all are published - but I have 16 in total. I used various tools to verify them, but all tools report back, that there ere no CNAME’s at all. Domain is ph-internet.de

All are configured to have DNS only, not proxied.
In the settings, the CNAME flattening is configured to “Flatten CNAME at apex”. I don’t have any option to disable CNAME flattening at all, just could change to “Flatten all CNAME’s”.

Any idea, what is wrong here?

Cheers Peter

Do the names respond to queries for A and AAAA records?

An example hostname?

Guessing at a popular CNAME example i tried autodiscover which appears to resolve just fine (as a CNAME).

dig autodiscover.ph-internet.de

; <<>> DiG 9.10.6 <<>> autodiscover.ph-internet.de
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16425
;; flags: qr rd ra; QUERY: 1, ANSWER: 7, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;autodiscover.ph-internet.de.	IN	A

;; ANSWER SECTION:
autodiscover.ph-internet.de. 300 IN	CNAME	autodiscover.outlook.com.
autodiscover.outlook.com. 60	IN	CNAME	atod-g2.tm-4.office.com.
atod-g2.tm-4.office.com. 60	IN	CNAME	autod.ms-acdc-autod.office.com.
autod.ms-acdc-autod.office.com.	10 IN	A	52.96.109.232
autod.ms-acdc-autod.office.com.	10 IN	A	52.96.111.56
autod.ms-acdc-autod.office.com.	10 IN	A	52.96.111.40
autod.ms-acdc-autod.office.com.	10 IN	A	52.96.111.120

;; Query time: 157 msec
1 Like

Looks like a problem in the overall query for CNAME - when I query any CNAME with dig, it shows up. Now also my configured services I need the new CNAME for are working.
Think it was a DNS timing issue and I was thinking, it’s not working as no CNAME are displayed at all.

So at the end, no issue, just a cosmetic issue when querying for CNAMEs - good to know for the future!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.