No caching on home page for logged out users in WordPress

We run a blog-type site where we featured articles on our home-page. When we post something new, it is extremely time-sensitive. For users logged in, they see it instantly. For users logged out, they see it when their cache clears.

We don’t want to simply disable caching on the home page as we also have plenty of content there which benefits from caching. But it is imperative that logged out users see the newest information as soon as it is posted

How do we mitigate this while still utilizing caching to the fullest extent?

Cloudflare doesn’t cache home pages by default, and for pretty much this reason. How did you set it up?

1 Like

Well, that makes perfect sense, actually.

I set it up through SiteGround, our host.

  • Argo Tiered Cache
  • Ignore query string
  • TTL - 30min
  • Crawler Hints ON
  • Always Online ON

SG has their own cache. Maybe that is actually what is getting in the way here?

Possibly, but without knowing the site URL, we can’t check.

Of, course! The site url is

As you can in the screenshot below, the only caching is from Siteground. CF-Cache-Status is DYNAMIC, which is default for HTML, so it’s not a cache HIT or MISS.

x-cache-enabled is True, and that comes from the server, but there’s usually a x-cache-status header as well, but I’m guessing it’s not cached, though I don’t know what x-proxy-cache-info does.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.