No cache on JSON

Hello.
I found “Cache Everything” can’t cache JSON.

I want to cache JSON on cloudflare CDN . How can I do this , do I need business plan? Thanks.

1 Like

Why would you think so? What exactly were you trying to do?

because other content types are returned from cloudflare CDN except JSONs.
image

I added ignore query str.
image

.json files are not cached by default, however you can configure a page rule.

Your examples do not seem to refer to your own host behind Cloudflare though and so you wouldnt have control over that. Whats the actual link to your .json file?

I applied this setting to cover all urls and extensions (I thought)

May I know how to cache JSON.

mingalartech.com does not seem to be proxied in the first place.

Also, the question was about the link to your .json file.

So in short, your host is not proxied and the URL you posted does not seem to be part of your domain. So Cloudflare’s caching wont take effect in any case.

Thanks.
https://api.mingalartech.com/v1/post/swjfashion.com/swj-1.json
(You can Find cache HIT in the plain json because of its content type)

But here


(Please find by “swj-1.json” in network)
You can see the difference

Thats the same URL. Is it not?

For me it is a cache hit as well. You do have a query string, but the setting you referred to earlier should take care of that.

image

Can you see cache hit from cloudflare CDN ?
It is not from disk cache and not also from origin . please can you ?

See my screenshot please.

Thank you so much for help . May be I am cached . :slightly_smiling_face:

Clear your browser cache and try again and check for the caching status.

This topic was automatically closed after 30 days. New replies are no longer allowed.