Nginx Reverse proxy throwing 522 error

Description of Setup
I recently moved my Ubuntu 20.04 Linux server from point A (Comcast network) to point B (fiber network) for speed/reliability reasons.
I host a few websites to manage my Docker containers through a NGINX reverse proxy, and they are routed through Cloudflare for the security and speed benefits of course.
I am using SWAG by LinuxServer to handle the reverse proxies.
Before the move, I had all of my A Records for my subdomains proxied through CF and they worked perfectly.
The firewall I use is UFW, and SWAG is bundled with fail2ban out of the box.

** Description of Problem **
After getting everything on my server transitioned over to my new network, the only thing that is not working to my liking is the NGINX proxy.
If I keep the :orange: Proxy enabled, the pages load halfway, and I get a 522 Error in my developer console:

If I :grey: disable the Proxy, everything works as expected. I am able to connect, and the console is free of errors.
I have checked everything on my end and researched a good amount about my issue, and I am just wondering if this could be something on CF’s end that I am missing.

** What I’ve tried **

  • I have allowed all the IP Ranges that CF uses through my IPtables (which is used by both UFW and fail2ban)
  • I have verified that my NGINX configs are correct, as they have worked previously on my old network, but I am open to suggestions on where to look to figure this out.

Marking this as solved.
I had my ISP replace my router because it was causing me connectivity issues unrelated to this problem.
And as a result, the underlying 522 error was fixed.