Nginx proxy on 443 getting error 522

Proxy: nginx version: nginx/1.15.0 (Ubuntu)
Proxy uses self signed certificate: [SITE](https://www.newhorizons3000.org/)
Cloudflare: SSL Option Full
I tried with origin cert from Cloudflare with failure 522.
The trace fails with 522.
I am at a loss for further trouble shooting and recommendations would be appreciateded.

Can you connect to the origin server directly? (By pausing Cloudflare for the domain in the dashboard or by turning off the proxy for the DNS record).

Is port 443 (and maybe port 80) open on your firewall and Cloudflare IP ranges allowed (or not blocked)?

I’m getting a timeout on HTTP as well, but I guess you may be using only HTTPS.

When it is working, you should really use “Full (strict)” with the Cloudflare origin certificate, rather than the self signed certificate.

When Cloudfae is dns only it goes through. Only port 443 is open. No blocking of IPs. Il change over to strict and the origin certificate and try. Ill use *.newhorizons3000.org for CN, since I will want to proxy multiple hosts. Thank you.

I tried everything I can think of, here is the direct link to the public ip

https://68.101.24.123

While i can go to it and receive insecure connection. the only thing i can think of is the host name which is www,newhorinzons3000,org. I would like to trouble shoot the connection with Cloudflare but can not find docs.

Any pointer in the right direction would help.

Thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.