Has anybody come across this before? I’m running my sites through nginx + cloudflare. Been working for a couple of years with no problem but today all of my sites went down with “too many redirects

I haven’t tinkered with my cloudflare settings so have always had Always Use HTTPS and Automatic HTTPS Rewrites on with no issues, and encryption mode at Full. I tried turning these off/use full (strict) and nothing changed. Paused cloudflare and the sites worked.

Nothing unusual about my nginx configs either as far as I could tell, and they all had a listen on port 80 which simply return 301 https://$host$request_uri; and a server block for port 443.

Anyway, what fixed it, in the end, was to not redirect on port 80 but to duplicate the 443 block and change it to port 80.

It’s basically doing the same as before but with one less redirect, surely that cannot be an issue - and why now?

The issue should be with the Nginx config vhost file for your site, otherwise the SSL certificate and/or SSL Settings at Cloudflare Dashboard.

We could try and ask you to share your config file, however this should be more related to the Stackoverflow or similar forums.

Nevertheless, may I ask if your Website is working fine when you use the “Pause Cloudflare for this Site” option from the Cloudflare Dashboard? :thinking:

Are you using Flexible SSL option maybe? :thinking:

Furthermore, have you tried using a different Web browser regarding the cache files, or Private/Incognito mode, if so, is there anything different? :thinking:

1 Like

Hey. So I’m using Full encryption (also tried Full (strict) but still didn’t resolve), when pausing cloudflare - it works (which is why I assumed I should be posting here but maybe you’re right and it might be better suited for StackOverflow), I didn’t try other browsers but did try incognito in Chrome and it wasn’t working.