New (wordpress) subdomains displaying 404 Not Found

Hi!

Really hope there is something obvious I am missing and someone can help.

I have a domain which has a wordpress multisite installed on it. The website itself works fine (jaycvisuals.com) but I am having issues with subdomains within the network unless the URL is mapped.

I am trying to get ‘panthers.jaycvisuals.com’ and ‘sihkforgiveness.jaycvisuals.com’ up and running but I am receiving 404 error pages.

I’ve taken all of the steps I did for my working mapped domains but I am not getting the same results. Does any one have any idea why this might be?

Thanks!


Ive got exactly the same problem!! The subdomain dns pointers dont seem to ever change…m

Your using cPanel, for the new subdomain did you add it to cPanel too?

This is a pseudo-404. Your origin server is redirecting with a 302 to a page called 404.html. This redirect is not related to Cloudflare.

2 Likes

Hi, thanks
Yes I did. The second screenshot shows that one of the sites was working on the http version before connecting to Cloudflare.

Thank you!
Strange (to me). Do you know why this may be or how to stop this from happening?

Have gou added the domain with gour web host control panel

No do not recommend that Flexible ssl is not Safe

@Neeraj0001 It’s just a test to diagnose his issue. Please understand the process, don’t get in the way.
It he’s worried about the security, he can just do a cURL test to his origin with the specified IP to diagnose.

2 Likes

Ok , But Do not Recommend Flexible SSL after troubleshooting the issue

@Neeraj_1 Nor did I.

@website7, heres 2 cURL commands you can run trouble shoot directly to your webserver, bypassing Cloudflare.

First probe HTTP 80 as shown in your first screenshot,

curl -v http://sihkforgiveness.jaycvisuals.com/ --resolve sihkforgiveness.jaycvisuals.com:80:162.241.253.36

And second probe HTTPS 443 which is what your having trouble with.

curl -v https://sihkforgiveness.jaycvisuals.com/ --insecure --resolve sihkforgiveness.jaycvisuals.com:443:162.241.253.36

As @cbrandt pointed out, its being 302 redirect.

Notably from the output in the HTTP test I see its a NGINX server responding, and with the HTTPS test its an Apache server responding.

I will suggest again that you ensure the proper “ServerName”/“ServerAlias” is setup for 443, not only 80.

1 Like

Thank you for your replies. I am working through them now!

Not a problem at all. I very much appreciate you taking the time to look into my issue and respone. Also, I think you are on to something here!

sikhforgiveness.jaycvisuals.com did not work, but also did not produce a 404 error. Instead I received “ERR_TOO_MANY_REDIRECTS
And as for the other site, panthers.jaycvisuals.com did work (screenshot attached; it is a cloned site).

What would these results suggest to you?

It’s in a redirect loop because your WordPress is redirecting to HTTPS as shown in the cURL request screenshot before.

You could either fix the issue with your origin server not having a vhost for 443, or alternatively you could update your WordPress to http so it stops automatically redirecting to https.

2 Likes

Thank you so much for all of your help. Especially you @user2765 and @cbrandt I have the sites up and working now with the correct SSL settings.

Ultimately you are both correct and it was an incorrect code within my server which was triggering issues with the connections and causing loops.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.