New Wordpress Posts not showing on Homepage when using APO

Title says it all

I run a script every night at 11pm that moves an audio file from storage onto my public server. It then generates a Wordpress post with an image of the waveform and a player to play the file.

When you then visit the site the next day the Homepage does not display the post.

The only way for a non-logged in user to view the new posts is to put ?s=&submit= after the url. eg: example.com?s=&submit=

The post itself is just a regular post, nothing strange etc… If I disable APO the posts display as expected.

What cache setting do I need to change to fix this issue?

Extra info:

I run APO on 3 sites, the root (and www.) as well as 2 subdomains. The issue is occuring on one of my subdomains

It maybe specific to the way how the new post is generated, Cloudflare WP plugin hooks to new post events and sends purge requests to Cloudlare API. I suggest to send Purge API call as a part of the script run to make sure APO invalidates the cache.

2 Likes

Thanks will give that a try

So the API works…

BUT…

You can only purge the entire zone, you can not do a single sub-domain (unless on an Enterprise plan)

It’ll do, but it’s not great.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.

I actually suggested purging API for sub-domain’s homepage, you can purge list of URLs on any plan.

1 Like