New user struggling with SSL - please help


#1

Hi there, I’m totally new to Cloudflare. I just added my site and am getting blazing fast page loading speeds - which was my main reason for joining so am well happy with that. However, I tried to switch my site from HTTP to HTTPS using the universal SSL cert. It worked, but on most pages when viewing the site in Firefox it displays an amber, unlocked padlock symbol next to HTTPS - to indicate the page isn’t secure. I panicked and switched off the ‘page rule’ to convert to HTTPS and its still doing it though. I’d really appreciate some advice . Please can anyone help.


#2

What is the domain?

At a guess I would say mixed content.


#3

here’s the domain. You can see homepage is insecure…


#4

image

Works fine for me with HTTPS in both Firefox and Chrome. Try clearing your browser cache.


#5

great! Thank you. It works fine. Just needed to clear my cache. Do you think i need to go back into Cloudflare and re-apply the page rule , or as it seems to be working, just leave it as is?


#6

If you have the ‘Always use HTTPS’ setting enabled in the crypto section then it is fine. It is redirecting OK for me from HTTP to HTTPS.


#7

Yes, i’ve got that setting enabled. All good and I am well happy + my page load times have more than halved. Thanks for your help. I appreciate it as this is all new to me


#8

Great, no problem :slight_smile:


closed #10

This topic was automatically closed after 31 days. New replies are no longer allowed.