New to CloudFlare question about mail

Hi everyone,

I am having my host change the name servers over to clouflare today. I asked them about my emails, would they be interrupted, etc. and they said:
After we change nameservers, you need to assure that mx record mail.HorrorNewsNetwork.net is added to your cloudflare account.
And make sure that A record mail.HorrorNewsNetwork.net 72.34.34.3 is also added in account.

Does anyone know where I would go to do that? I am sort of new at this so it is a bit nerve-racking knowing my site might be down/email not get delivered.

Check out this support article

https://support.cloudflare.com/hc/en-us/articles/360019093151-Managing-DNS-records-in-Cloudflare#h_60566325041543261564371

You can add those two records under “DNS” in the Cloudflare dashboard.


Thank you guys!!

Hey guys,

I have another question (sorry).
When I tried to do the A mail setup I get this message:

The MX seemed to go through ok as you can see through the highlight below. Will that work for every name @mydomain.com, for example, [email protected], [email protected], etc? Or do those need to be setup separately? See the next post for that image:

No worries! There is more than one way to set this up actually :grinning_face_with_smiling_eyes:

Your configuration before the move to Cloudflare looks something like this:

horrornewsnetwork.net MX horrornewsnetwork.net
mail.horrornewsnetwork.net CNAME horrornewsnetwork.net
horrornewsnetwork.net A 72.34.34.3

Does that make sense? The end result is the same as the setup your provider recommended in the initial post. You can go with the approach you prefer.

Hi Svanlund. Thanks for your reply. So, does that mean I have to add 3 more records?

horrornewsnetwork.net MX horrornewsnetwork.net
mail.horrornewsnetwork.net CNAME horrornewsnetwork.net
horrornewsnetwork.net A 72.34.34.3

I’m sorry, this part is really new to me.

No, it means that you have identified two ways to achieve the same outcome: Your current DNS configuration over at the (soon to be) previous provider and the setup they recommended (mentioned in your first post). You only need one set of records to make email work.

What you want is essentially:

  • Anyone sending email to your domain should talk to that specific IP address.
  • The “mail” subdomain should point to the same place (possibly offering up a webmail interface?)

So what you need is:

  • A single MX record for the root domain (@). Since you can’t point the MX record to an IP address directly, you point it to horrornewsnetwork.net (A record already present for your website, so all good) or mail.horrornewsnetwork.net (see next bullet point).
  • If you want to use the “mail” subdomain in the MX record and/or for webmail access in your browser, add “mail” as an A record pointing to the IP address.

Hi @user6461

the really important bit for your MX record is that the target MUST be :grey:. In the screenshots you have it is :orange:

image

Similarly, the record for ftp needs to be "grey:.

Hi Savlund. I tried to add both and they say they already exist. Here is a shot of my screen.

Thanks Michael, hopefully this looks Ok?

I would suggest you remove the first MX record and then change your A record on line 5 to DNS only (grey-clouded).

Edit: Note that this will disable almost all Cloudflare features since your website won’t be proxied through Cloudflare. There are other ways to set this up, but this was the most simple change given your current configuration and goal (make email work).

Hi Svanlund. Here is how it looks now:

Looks pretty good to me, but what are those warnings about? (Do you see any messages when hovering?)

The origin IP address is exposed. For protocols like FTP and SMTP that is unavoidable.

1 Like

Yes, like Michael says below those messages say: This record exposes the IP behind www.horrornewsnetwork.net which you have proxied through Cloudflare.

Is that something I need to fix/change? I really appreciate all the support.

I just tried to connect to my FTP and it kept timing out. Do you know if there is a setting that needs to be changed once you switch to Cloudflare?
FTP-issue

Your FTP server is at ftp.horrornewsnetwork.net

Don’t use ‘www’, because you need it to set to :orange: Proxied.

Wow! That fixed it Thank you!

1 Like