New to Cloudflare, email not working

Answer these questions to help the Community help you get started.

What is the domain name?
toobzee[dot]com

Describe the issue you are having:
Can’t send or receive email.
Also, my 2 MX records have warnings:
This record exposes the IP address used in the A record on toobzee[dot]com, which you have proxied through Cloudflare.

My Cloudflare DNS records have:

  • 9 A Records, all proxied except for localhost. The Content for all (except local) is my IPv4 address from Bluehost.
  • 7 CNAMES, all proxied.
  • 2 MX records, my domain and mail[dot]domain[dot]com, both are DNS Only

What steps have you taken to resolve the issue?

  1. Watched Cloudflare Community Tutorial - Troubleshooting Email Delivery Issues on YT and followed suggestions. None worked.
  2. Searched Community Forum, but was unclear on how to fix my issue.

EDIT: Also, when I change the A record for mail (as suggested in /dns/manage-dns-records/how-to/email-records/ in the CF comunity), I get this warning:

This record exposes the IP address used in the A record on autoconfig [dot] domain [dot] com. Enable the proxy status to protect your origin server.

You really need to unproxy that “A” record for mail. Yes, it’s going to. expose the IP address of a proxied hostname, but that’s one of the downsides to hosting email on the same server as your website.

Unproxy your mail record, and that should help quite a bit.

1 Like

Thanks. I’ll do that and try to retrieve my email again.
So, the warnings are basically telling me that the email server should be separate from the web hosting. (?)

Update: Yep. A flood of emails is coming in now. :slight_smile:

I’ll start looking for a separate email host.

2 Likes

Or… will using Cloudflare’s Email Routing option (Create custom email addresses to use whenever you do not want to share your primary email address.) allow me to set the A record back to proxied and solve the issue?

Cloudflare Email Routing is not the right solution here. It is used to forward email to mailboxes at other domains and only applies to incoming email. You still need a properly authenticating outbound setup elsewhere.

2 Likes

Understood. Thanks and much appreciated! :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.