New to cloudflare - DNS has propagated, but site is still down

I’m totally new to this and signed up for Cloudflare b/c my site whartonalums.org was super slow. I’ve changed the nameservers with my host, Bluehost, and also changed the IP for the A Record localhost to point to Bluehost. However, after checking that DNS has propagated around the world, the site still isn’t working.

  1. The A record is still showing DNS only and I don’t know how to change it to be proxied. Not sure if that’s causing the outage.
  2. I’m open to all other suggestions, keeping in mind that I’m not that technical

This is certainly a weird look. Was your site up and running with HTTPS before you added it to Cloudflare? What’s the SSL setting here? Full/Full(Strict)?

I see your site redirecting from HTTPS to HTTPS in a continual loop.

It looks like you have configured Cloudflare “Always Use HTTPS” with SSL Mode Flexible, and also configured your Origin server to enforce HTTPS. It also looks like your have a valid Lets Encrypt certificate on your origin.

Flexible is probably the issue, and you can resolve it by setting your SSL Mode to Full (Strict) on the SSL/TLS Overview page of the Dashboard.

3 Likes

Yes, it was using HTTPS before adding Cloudflare.

Thanks. I’ve changed back to full (which Bluehost asked me to change to Flexible.

I’m not sure how to change the Origin server to not enforce HTTPS. Can you please point me to where that’s managed? All of this was set up on the initial setup, but I don’t see the location to change it now.

Finally, on the Lets Encrypt…I have no idea what that is. :slight_smile:

I figured out how to change the “always HTTPS” but now the site is displaying the dreaded 521 error. I’ve asked bluehost to add the IP ranges on their end. Is it likely that would help?

Probably, yeah. Ideally they would block all non-Cloudflare IPs and allow all the Cloudflare ones specifically.