New SSL not working

I have registered a new SSL and all looks good in the settings (Flexible SSL is Active, rule setup, https forced etc). However, the secure site will not load with ERR_SSL_PROTOCOL_ERROR. Site is Any help appreciated!

I’m seeing a good Certificate and the site is fairly well setup. There are some Mixed Content warnings due to resources from x10host that aren’t using HTTPS. Unfortunately, it looks like your x10host resource can’t load over HTTPS.

It seems x10host is acting like a CDN for your images. Is there a way to load your images from your WordPress instead of x10host?

So I can’t get or to load at all. The only one that actually works is non-https builddevon dot com

I don’t know what you mean by x10 acting as a CDN? It’s just a WordPress site.


The www redirects to the naked domain. And HTTPS is loading for me. But something in Wordpress is telling the browser to load images from another domain:

Otherwise, the HTTPS site is loading well in a global test:

Ah great! I have fixed those absolute URLs. Still can’t get https to work though - very odd!!

That very last one, callout-1.jpg is still coming from x10host.

As for the load issue, if you have Chrome, hit the F12 key to open Dev Tools and select the Network tab. It’s what’s in my screenshot for your resource list.

Load your site, then click on one of the resources from your domain. A side pane will open up and show you your connection. It should be hitting a Cloudflare IP address beginning with 104 with some other Cloudflare Response Headers.

Yeah I don’t even get that far…


Give cURL a try:

Ah, that’s a bit beyond my comfort zone I’m afraid!

Now I’m seeing a complaint about callout.jpg. I see there’s a 301 redirect for it, but that’s still raising a red flag.

That should be fixed now…

It’s weird because I can see the site if I use data on my phone but not on wifi - must be an ISP thing?

Most likely DNS. It’s a brand new domain, which takes time for the world to recognize. A couple of days is typical, but definitely within a week for full global reachability.

This topic was automatically closed after 31 days. New replies are no longer allowed.