New Plesk hosted domain

Have a new domain name bibleadvisory.com, it is the 3rd day since I tried to setup dns and still no sign of cloudflare or anything when loading the site, I know cloudflare registrar with Plesk setup can be tricky, I tried disabling Plesk dns and putting in the 2 cloudflare name servers, any suggestions?


Getting this message on Plesk

It looks like there are records:

1 Like

I had tried importing the Plesk dns settings into cloudflare to help with email etc, but I left out the Plesk new servers

How did it get that info? I think I looked at something similar yesterday, but not sure what is wrong

ATM it seems like you are encountering a redirection-error:

As you are using Plesk you dont have to set the DNS up on Plesk side, because you do it on Cloudflare. Setting up the DNS twice is not required. But ofc if you do it correct it will also work. I would recommend using just Cloudflare as DNS.

1 Like

That’s what I saw as well. It’s bouncing back and forth between HTTP and HTTPS. As @M4rt1n suggests, I recommend you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com. The link is in the lower right corner of that page. Give it five minutes to take effect, then make sure site is working as expected with HTTPS. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

1 Like

Thanks, glad that didn’t take much, I would not have figured that out, much appreciated I got it ssl enabled

1 Like

Now just to get off work and set it up :wink:

Some other hints:

  1. if you can please use PHP 8 (you can install it in Plesks installer)
  2. turn off expose_php in each php.ini for all versions in /admin/php-handler/list (in Plesk)
  3. hide your Wordpress version.
    remove_action( 'wp_head' , 'wp_generator' ); (this will remove it at least from the header)
1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.