New install of WARP Client “we were unable to register your client with the WARP service"

Hello,

I have just downloaded and installed the latest WARP Client (Cloudflare_WARP_Release-x64 v23.7.160.0) on Windows 10 (x64 22H2) but it persistently tells me “we were unable to register your client with the WARP service”.

Cloudflare WARP.exe (also all the other exe’s in that folder) has unrestricted internet access though my firewall (TinyWall) and I am using Windows Defender antivirus which has not indicated any problems.

I am located in Bucharest, Romania and the local Cloudflare servers here are showing as operational.

P.S This is for personal desktop PC use only, without any other Cloudflare services and my PC and router DNS is already set to 1.1.1.1 / 1.0.0.1

Please advise.
Thank you for your help.
Tony J

I have the debug logs but no way to attach them here.

Here is an extract from cfwarp_service_log.txt which as become 525KB in just 50 minutes!

2023-09-23T10:47:54.868Z DEBUG warp::warp_api: Sending API request POST api.cloudflareclient.com./v0/reg
2023-09-23T10:47:54.869Z ERROR warp::warp_api: API request error ReqwestError(reqwest::Error { kind: Request, url: Url { scheme: "https", cannot_be_a_base: false, username: "", password: None, host: Some(Domain("api.cloudflareclient.com.")), port: None, path: "/v0/reg", query: None, fragment: None }, source: hyper::Error(Connect, ConnectError("tcp connect error", Os { code: 10051, kind: NetworkUnreachable, message: "A socket operation was attempted to an unreachable network." })) }), retrying in 9.600863798s
2023-09-23T10:48:03.279Z DEBUG main_loop: warp::warp_service::ipc_handlers: Ipc request: 8250e008-f811-4395-9181-4f82e5267eac; GetDaemonStatus
2023-09-23T10:48:03.279Z DEBUG main_loop: warp::warp_service::ipc_handlers: Sending IPC status update: Unable(RegistrationMissing)
2023-09-23T10:48:03.279Z DEBUG main_loop: warp::warp_service::ipc_handlers: Ipc Broadcast ResponseStatus: Unable(RegistrationMissing)
2023-09-23T10:48:03.279Z DEBUG main_loop: warp::warp_service::ipc_handlers: Ipc response: 8250e008-f811-4395-9181-4f82e5267eac; Success
2023-09-23T10:48:03.398Z DEBUG main_loop: warp::warp_service::ipc_handlers: Ipc request: 077eed14-9cbc-4047-a595-e49a6d20b0c6; GetAppSettings
2023-09-23T10:48:03.398Z DEBUG main_loop: warp::warp_service::ipc_handlers: Ipc request: 5a0819ec-bede-4843-84a6-b454d77ac4b8; GetAppSettings
2023-09-23T10:48:03.399Z DEBUG main_loop: warp::warp_service::ipc_handlers: Ipc request: 99917109-a5b9-4e14-995b-0786a011d7fa; GetAccount
2023-09-23T10:48:03.399Z DEBUG main_loop: warp::warp_service::ipc_handlers: Ipc response: 99917109-a5b9-4e14-995b-0786a011d7fa; Error: Missing registration. Try running: warp-cli register
2023-09-23T10:48:03.401Z DEBUG main_loop: warp::warp_service::ipc_handlers: Ipc request: d5cf04e6-ca59-45ab-9f25-4aa8cdb736e5; GetAppSettings


I also treied this without any success:

screenshot
Screenshot 2023-09-23 210808

Tried reset all settings but no change

Is nobody able to help with this? I tried everything with no change. Repair install, uninstall and reinstall (twice) nothinmg works! It seems that the current Windows version is only meant for users on the Zero Trust platform and it needs a license key or account! I can’t find anything useful here or with a google search but it just refuses to work. Can someone please help. Thanks Tony J

On trying to run WARP again It offered to update to a new version 2023.9.248.0 so this was installed and when trying to connect it shsows this error:

Status: Unable to connect
Error reason: Registration Missing
Error code: CF_REGISTRATION_MISSING
Error description: Please connect to your Zero Trust organization and re-authenticate.
Learn more: Client errors · Cloudflare Zero Trust docs

The link above reads as follows:

CF_REGISTRATION_MISSING
​​
Symptoms

Unable to connect WARP

​​
Cause

The device is not authenticated to a Zero Trust organization because:

The device was revoked in Zero Trust.
The registration was corrupted or deleted for an unknown reason.

​​
Resolution

Launch the WARP client.
Select the gear icon and go to Preferences > Account.
Select Re-Authenticate Session.
Complete the authentication steps required by your organization.
If this does not resolve the error, select Logout from Cloudflare Zero Trust and then log back in. Logging out is only possible if Allow device to leave organization is enabled for your device.

However, my device has never been used on Zero Trust and I do not have a “Re-Authenticate Session” button on that tab - there is also no license key showing.

Hello @tjbuc, do you use an include or exclude split tunnel?

I have users who cannot connect to various IP ranges when their WARP profile is an “include” type.

However, if I put those users on the default WARP profile, then things are OK.

Hello a.collett

Thanks for your reply.

I downloaded WARP for personal use on a single desktop PC. I am not using it with another service such as “Zero Trust”. However, it does not register as you can see in my earlier posts. I am not using any split tunnels and have not altered any settings in WARP, it just refuses to register immediately after installation, or later. Muliple uninstalls - reinstalls have not changed the situation. Also, I am not using a VPN or anything else that could cause connectivity problems.

I tried installing WARP on a laptop here and strangely that worked. The only thing that is different is that the desktop PC connects via an Ethernet cable (it does not have a Wi-Fi adapter) while the laptop uses Wi-Fi (it does not have an Ethernet port) but both are connected to the same home router.

I am completely at a loss to explain this and would welcome any help or suggestions.

Thanks
Tony J

Ah okay. Then we have different situations!

The only other thing I can think is to check there aren’t odd DNS settings on the Desktop.

Other than that… Is the date and time set correctly? You’d probably see other issues though if it wasn’t.

Thanks for your reply. Yes the time is synchonized every 24 hours and is correctly set for my location. My Desktop DNS settings are set to 1.1.1.1 primary and 1.0.0.1 secondary. I tried setting the adapter back to using automatic assignment from the router (which also uses those DNS settings anyway) and nothing changed. Thanks for replying :wink:

1 Like

I found the answer:

Checking Tinywall firewall’s blocked connections list showed that it was blocking:

warp-svce.exe (5500) outbound connections to 162.159.162.1 port 443 (HTTPS)

Not sure why since this and all the other WARP exe’s in C:\Program Files\Cloudflare\Cloudflare WARP are set to allow unrestricted connections. Even when selecting those entries and clicking unblock they were still being blocked.

So I briefly set Tinywall in learning mode - WARP is now registered and connects ok. Set Tinywall back to normal mode immediately after and everything continues to work.

Very strange. I hope it helps someone else but I guess this a rare occurence.

Tony J

1 Like

Hi, I have also been having the same problem with the error code CF_REGISTRATION_MISSING. However, I am quite unsure about what is Tinywall. Is it a third-party application that you have downloaded or is it a system program that every PC/laptop already has installed?
I would appreciate your reply regarding this problem

Bryan

Hi Bryan

Tinywall is a 3rd party firewall program: https://tinywall.pados.hu/

My problem was that it was blocking access to the WARP registration server.

If you have any 3rd party anti-virus with built in firewall (which many have) that may be causing your problem. You could try disabling the anti-virus before you open WARP and see if it resolves the problem. Once WARP is registered the anti-virus is unlikely to cause further problems.

I was able to install WARP on a Laptop PC here without any problems, only my desktop PC with Tinywall installed had a problem.

I hope that helps

Tony J

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.