NEW Images created in the wp-content/uploads folder gives 404 error

I have disabled hotlink protection and I have tried to enable Development Mode so ALL caching is disabled. But nothing works.

But I get 404 page error when the image is actually on the server.
That means a page with my own design…

if I try to get an image that is not on the server I get a server error…

404 Not Found

The requested URL was not found on this server.

Try it out here:

Image that works: https://myfutcard.dk/wp-content/uploads/2022/10/Storyyy-min.png
Image that is present on server: https://myfutcard.dk/wp-content/uploads/2022/10/Storyyy-min1.png
Image thas is NOT present on the server: https://myfutcard.dk/wp-content/uploads/2022/10/Storyyy-min2.png

What is wrong here?

Weird issue indeed. when i use cURL to retrieve the image on https://myfutcard.dk/wp-content/uploads/2022/10/Storyyy-min1.png it returns the image successfully.


:point_up_2: it was the retrieved image.

but it returns a 404 on browser. it could be that some Wordpress plugin is messing up something.

But it is only when on Cloudflare it is an issue.
Do you Still think it is a plugin issue?

Nikolaj

Myfutcard.dk

If you look at your origin server logs, what URL shows up for the 404 response?

Is that the debug.log? Or what log is that? Traffic log on the server?

Nikolaj

Myfutcard.dk

But now it works on the browser as well… but the original images that it does not work with still not working.

Hilsen / Regards

Nikolaj

Myfutcard

This image is not working at the moment

hahaha… seems like something is very strange because this forum can show the image… Very strange.