New domain not allowing google site verification

As you can see from the failed note in the screenshot above, I tried the HTML file method and that failed. I have no idea how to add the HTML file though I gave it a fair shot.

Here is another screenshot of the Alternate methods tab shown in grey above.

No. You no longer have the infinite loop, however you list only one private IP that can never be the source of an email connection to any of your recipient’s mail servers, and you end the statement with +all which renders the SPF record powerless by overriding all checks with a mandatory pass (even when they fail).

Cloudflare has an SPF explainer that is worth a read. You can find another at dmarcian that goes more in depth. There is also a forum at dmarcian if you need to have deeper conversation on that topic that what is appropriate at Cloudflare.

1 Like

That TXT record is resolving:

google-site-verification=6_omFPG5Oimc_4IObs3KBYv-5fz38guJ4x4ikmpj_D4

I’m not sure why verification is failing if that’s all you have been asked to add.

2 Likes

Thank you so much for your replies. My domain I registered is still not working. I am stepping up my work on this as it really seems that this should work. I continue to appreciate any help on this as I cannot understand any reason why this continues to be so difficult or any reason why it should not work.

Hello,

Is this still an active thread? I have never used a forum like this before trying to obtain assistance with something paid like a domain registration. I wonder if I should start a couple additional threads requesting assistance from Cloudflare since this is something I paid Cloudflare for in order to register. Any help continues to be greatly appreciated. Has anyone else actually created a free google sites website and successfully linked it to a domain paid and registered through Cloudflare? In other words is this actually possible? It is bizarre to me that a full month in, I still have ZERO success accessing my paid registered domain. Isn’t this the most basic and standard thing? How could a domain registration platform allow it to be so difficult for a new user to link a website to a paid registered domain? I realize this could simply be standard in order to steer the vast majority of people who may attempt to learn how to link their domains themselves into paid subscriptions paying monthly or annual fees into the hundreds of dollars, but if you pay to register a domain, shouldn’t it at least be easy to do the most basic thing which is linking that domain to a standard site made using something as standard as GOOGLE Sites?

Again, I greatly value any and all of you who have reached out to help. I realize it is none of your responsibility at least as far as I can tell there is no one who actually works for Cloudflare designated to assist paid domain registrants like myself actually get the paid domain to work.

Many thanks

Hello,

Thank you so much for reaching out. Should I delete all my DNS records and try to start from scratch to see if that will allow my paid Cloudflare domain to link to my free google sites website? I have done everything I know to do and everything I have been able to find instructions for both on google sites, Cloudflare and from helpful folks like yourself.

After more searching, I found a google search console DNS setup wizard that seems to have satisfied the google sites verification. I have also added the Cloudflare type A record entry after the wizard rewriting in order to once again satisfy the Cloudflare domain record page so that there are no other outstanding requirements listed. This seems like good progress. I have tried 2 different CNAME target destinations trying to see if either of these makes a difference in actually producing the website when I enter the domain name in various browsers. The domain name is still not producing any results other than the message: failed to open. The google wizard produced a slightly different CNAME record destination target in my Cloudflare than the target address shown in the google console written instructions. Maybe with this tiny hopeful progress using the google console search wizard, perhaps I should just leave this alone for now and check back in 12-24 hours to see if anything changes with any more hopeful progress like the website actually coming up when the browser is pointed to the domain name url.

Hello,

Thank you again for your previous reply to assist. I have still not been able to get my domain to produce my website in a browser. I have posted a number of updates here detailing my continued best efforts to make this work. Are you able to look at this again and perhaps even ask any questions that may be helpful to figure out how to get this to work?

Many thanks in advance.

Turn proxy status on for both records

1 Like

I can share a couple of reasons.

You have a CNAME for www.geniuseducation.net that points to geniuseducation.google.tld. There is no such domain as google.tld so you are in effect pointing your www.geniuseducation.net name nowhere.

You have your apex name geniuseducation.net configure with an A record that points to a private network IP address 192.168.4.38. Due to the way private network addresses work, no one can reach that address from the the public internet, so it makes no sense to return that address here.

You are still using the same private IP in your SPF record. I explained over two weeks ago how that will not work.

2 Likes

Thank you again. I am rereading the responses I have received as well as the links, suggestions, pages and related pages information.

When I first saw the Cloudflare requirement for ip4 in the DNS records, I wondered why I would use a private ip4 number. I understand now that I cannot. What I have no idea how to figure out is exactly what I need to enter for the ip4 address in either the A or the SPF records. Can you provide some guidance how I could ever figure out what to enter for these ip4 values?

Thank you again. I truly value and appreciate any and all assistance here.

Would you be able to delete the private ip4 value included in responses above?

Am I rightly concerned about the ip4 value being included in this thread?

I am no longer getting the failed to open error and am getting a blank page with a notification error stating too many http redirects. I am sure this has been mentioned above. I just have clearly still not resolved whatever issues remain in my DNS records even as I continue reading and rereading instructions, reading online and doing everything I can to figure out how I may possibly be able to get these DNS records right so this website will load.

There is no reason to be concerned about the inclusion of a private IP in this topic. It is unreachable via the public internet and betrays no useful information. That same IP is very easily in use on thousands of networks on the planet at this very moment.

My advice to you is to either pause Cloudflare or keep the records set to :grey: DNS Only while you work with Google to get your site working correctly without the Cloudflare proxy.

Once your site works as expected over HTTPS you can then switch the records to :orange: proxied.

1 Like