New 525 Error

Yes… Go Daddy wants close to $94.99/yr in the US when you renew.

My 5-year contract with them ends in April… not sure how hard it is/would be to transfer 4 sites, one with a different domain, to another Hosting Provider.

Cloudflare has nothing between Free and $20/month. None of the sites are complicated or sell anything. I just do not know if Free would do everything I currently do… Word Press Site. I am willing to pay, just trying to do it as affordable and reliable as possible.

Also, I do not know how my e-mail would be affected or transferred. I use an e-mail service (Zoho) to manage (host?) my e-mail, using my domain name- [email protected]. Would I just need to add the MX record in the new Host or do I need to make changes at Zoho?

Before moving to Cloudflare I had an expired SSL Cert and it did not connect by HTTPS. That was a headache in itself. Even though I deleted the Cert, the file remained on the server and had to be manually removed by GoDaddy. That took a week to figure out.

I mentioned that to the GoDaddy support yesterday, he said he has seen that happen a few times. He checked and made sure all CERTS were removed from the sever and then put a self-signed one on.

I tried Strict, Full and Flexible (I believe I got the terms correct), non-worked. The issue was intermittent, to some extent. IF you hit refresh 3-6 times the page might load. Only to fail again.

I ended up removing my site from Cloudflare and reset my DNS in cPanel. GoDaddy encouraged me to re-try Cloudflare, but wait 24 hours–just in case. He said he know a lot of GoDaddy clients use Cloudflare and had good things to say about it. But he could not find the problem on his end. He was the best support I have had with GoDaddy. Tried troubleshooting using both server and Cloudflare variables.

I never got the 522 error.

Thanks for your help.

Going to try to set-up Cloudflare again tonight. Any advice/concerns on re-setting it up on a site that was recently removed?

I am near done re-installing/setting up Cloudflare. Do I need to revoke the prior Cert? I came across this page. I assume the one with the nearest Expiration date is the OLD one?

I think I got it working… Including the message above, can someone check to see if it will load.

I thought I got it to load…

I received a BitDefender (Anti-Virus Suite) warning that it was unsafe URL. Happened on 2 computers. After I over ruled it, it seemed to work fine on 1 computer. It might have been a Rule in Bitdefender, that was created when it was not SSL and it needed to be over rided.

On my Windows 7 TV Computer I am getting a “this page isn’t working right now”… after a while it went to an Error 524 this time.

That was after clearing the cache in the browser.

1 Like

@gary19 thank you for writing and feedback.

I hope you know which one is which :sweat_smile: (don’t revoke the wrong one)

Now when I check, I see a redirect loop in my Web browser 301 and/or 302.
Testing online, using below two tool to check this so far:

May I ask you to check if SSL settings is at Flexible SSL under the SSL/TLS tab of Cloudflare dashboard for your domain?, which is a know cause of this redirect loop (and mixed content too).

More about it here:

Otherwise, if it’s not Flexible SSL, then something about 301 HTTP to HTTPS redirection at your origin host/server → maybe some htaccess rule or something similar to check.

  • hopefully you are not using some Page Rule to achieve 301 redirection?

I revoked the prior cert. I am sure I did the correct one because I saved it as a word doc.

It is Full Strict now… and I am back to getting 525 error

I will not make any changes until I hear back from someone. I do not want to change it while some one is checking it.

This is something else weird…

CRAZY… Using the TV computer, which had a 524 error, I refreshed and got a 525 error and refreshed and got a partial load, some images missing, refresh again and now it is there with fewer pics missing,

And after a couple refreshes… they are all back.

Without changing anything in Cloudflare— Main page opens with HTTPS,

Link gets a warning of not secure with HTTPS crossed out.

Trying to Log In to Word Press — also has warning of not secure with HTTPS crossed out.

Can you click on Advanced for that Cert warning and show us what it displays? I’d like to see what it thinks the certificate is issued to.

Advanced for Cert… Where in cPanel or Cloudflare? I did not see it in either.

But this might be the/a issue. In cPanel I went to Manage SSL, I browsed for Certs and came across this. The DOT is on the self signed Cert.

Should I move it to Cloudflare? It seems like that might be the issue.

This one here:

This time when I went, I got the 525 error… refresh a few times and it loaded.

Yeah, but when it loaded, it was without the ‘www’. Maybe the server doesn’t have a cert that covers *

That’s why I wanted to see what “Advanced” revealed.

Did you see my comment about cPanel and it looks like Cloudflare Cert is not Active

I may have skimmed it a bit too quickly, but it’s making some more sense now. Does it let you select the other one that’s the Cloudflare Origin cert? That one looks like it should cover everything that would work in Full (Strict) mode.

I do not think that is the issue.

I can select it and it shows up in the area where I pasted it… if I open up browse Cert, it defaults to the self sign.

You mentioned * This is what it show on Cloudflare.

I turned on Always Use HTTPS— cleared the cache in browser. Went to the site— got 525 error, refresh—got partial load, refresh full load

I doubt this has anything to do with it. I occasionally see this error while on Cloudflare site. Not sure it if is an account related error or a page error.

That’s not the origin certificate. That’s an Edge Certificate.

As for the “Great News” message, I recall you may have removed your site from Cloudflare then re-added it. That would account for seeing this message until things settle in.

I see that the site is now using an Origin Certificate on the server with the correct hostnames.

It feels like we’ve done everything we can and are still stumped. Have you ever opened a Support ticket on this?