Network issues in Mauritius

Hi there,
We’ve been experiencing a lot of issues with cloudflare from Mauritius for the past couple of weeks.

We’ve been in touch with support, but they always come up with the same generic answer that our server takes too much time to respond.

However when we test from a remote desktop found in the UK, it works perfectly well. It only doesn’t work well from Mauritius with cloud flare proxy is on.

And the last event that points towards an issue with the Mauritius proxy is cloudflare.com itself was broken and using alwayson from Mauritius (Worked well from the UK)…

And this morning again, we’ve had to disable cloudflare proxy on a number of websites we host as it was very very slow (Once cloudflare proxy is off, the websites run fast again, which points again towards cloudflare, not the website itself as support always suggests when we raise the issue to them…)

Can someone take a look into this?

We have nearly 200 website on cloudflare here, and it’s not getting any better and getting to a point where we’re having to disable the proxy for our customers as it’s not working well from Mauritius using the Mauritius proxy…

It’s even worse when we use 1.1.1.1 resolver. It’s kind of OK when we use 8.8.8.8 resolver.

Thanks

Are you talking about a site on Cloudflare or a non-Cloudflare site? In the former case the resolver really shouldnt matter, unless you are embedding non-Cloudflare resources, in which case we’d be “switching” over to the latter case.

You mentioned 200 domains. Can you post a sample one?

Also, can you post a screenshot of https://cloudflare-test.judge.sh?

Though this would indicate an issue with Cloudflare’s website or with the connectivity between the proxy and the site, rather than the proxy itself.

Hi,
Here’s a screenshot of https://cloudflare-test.judge.sh/

Here’s a sample website https://bankone.mu/en/

I’ve made a video at https://www.loom.com/share/b70b7071839445289286e8e14143b0a7 which summarises it all.

Basically when cloudflare proxy is on, it’s a hit or miss whether the websites takes time to respond or not.
With cloudflare proxy turned off, it always performs well…

We have the same issue with all the others…

Can you drill down, which URL it exactly is, which is pending and at which step the request is at that point? Are you absolutely sure it is a URL belonging to your site? You are loading a lot from Google as well.

At second 25 you suddenly switch from non-proxied to proxied, without any visible changes.

For me, at least, your site loads fine via the proxy. Not blazingly fast, about six seconds, but then it is about seven megabytes as well. Also, I am not going via MRU of course.

For starters, I’d open a support ticket, maybe support can provide some feedback whether there are any known issues in MRU.

I opened a ticket, which is in-progress since 2 weeks now

Support always has the same answer, there’s a problem with the website…

I checked with others here who also use cloudflare, and they all have the same issue…

At second 25 yes, because chrome didn’t properly clear it’s DNS cache, which is why I then opened incognito window to test…

I also checked with my ISP with whom we have a 30MB IPVPN line, they ran some tests on our line and they confirm the same diagnostic as us, there’s a problem between the local cloudflare proxy and our server

Can you address my first paragraph? It would be important to know where it hangs. Is it always the same URL? Is it a URL of your site or a third party?

Also, post the ticket number, so that @cloonan can have a look too.


Though, do I understand you correctly, it is not just an issue with your site(s) but generally with any site on Cloudflare?

1 Like

the ticket number is 1762959

The URL is for all, it’s not specific to any one. Sometimes it works well on a URL, then a few seconds later you try the same URL and it hangs…
In my video example on loom I clicked on the logo to go back to the homepage, sometimes you can see it loads fast, sometimes it just hangs…

Sometimes it works, sometimes it doesn’t

You can check https://www.azuri.mu/ as well, from MRU, sometimes it’s ok, sometimes not after a few seconds of revisiting the same page…

I wasnt referring to the domain, but the actual URL where the browser seems to hang. The site loads but there is presumably a resource which does not load properly and that is the interesting bit.

But again, are you saying it only happens with your site or do you experience that with every site that is on Cloudflare?

@cloonan -> 1762959

1 Like

Last week the issue lied with https://www.cloudflare.com/about-overview/ which was timing out and threw the error in my first screenshot today.

Before that, we had issues with https://dash.cloudflare.com that didn’t return AJAX calls from the DNS screen.

We also get issues from other sites on cloudflare, like https://medium.com/ , https://www.okta.com , etc…

Same behaviour, hit and miss, sometimes it loads in under 2secs, other times it loads after > 10 or 20 secs…

I also get issues with https://www.galaxy.mu , which is on a different server, and uses cloudflare pro

Same works well from the UK, but is very slow from Mauritius

As I mentioned earlier though, that error would rather indicate an error of the website or the connection between site and proxy. That is not necessarily the same issue.

I am afraid this entire issue is something where the community here wont be really able to help. Only support can look into this.

Yeah, but support is not helping

We have issues with https://projects.invisionapp.com as well, also behind cloudflare…

Hence the tagging of cloonan.

I understand your issue, but in your case the community cant help. What you could do is try and debug what exactly fails under what conditions. But even that wont be a guarantee that it will be fixed, even if the issue is on Cloudflare’s side.

Now cloudflare dashboard is failing (Screenshot)

Again, this is not necessarily the same error you seem to be observing.

For starters, submit the error form. Then, try to get the connection ID and add it to your ticket. Based on that they might just be able to track what made that request fail and that - possibly - might also fix your general issue (if they are related).

Thank you, I see the ticket and have added myself to it to track internally.

This topic was automatically closed after 14 days. New replies are no longer allowed.