net::ERR_HTTP2_PROTOCOL_ERROR whmcs

Hello guys, im new here.

So i have an hosting company where im using whmcs for control panel.
For VPS we use virtualizor module.
Our Panel on whmcs won’t load and after some times it give net::ERR_HTTP2_PROTOCOL_ERROR on Devtool chrome console.
Screenshot: https://i.ibb.co/9NfRdw9/proof1.jpg
I contacted virtualizor support but they say is a connection problem and it was working like 2 days a go and they say to contact cloudflare.
I don’t know what to do, alredy tried alot of things for fix but nothing.

This is what virtualizor support said:
Hi,

Sir we tried to check on your server but it seems that something is killing the load.
I got NS_BINDING_ABORTED when Virtualizor tries to load the javascript and css.
I also tried to increase the memory limit as well but it did not help.
Also tried to increase the curl timeout limit but that also did not help.
It seems a cloudflare problem or beckend problem.

Let us know.

Please help me

If you are using cloudflare for that domain/ subdomain, then:
First, try to add Cloudflare IP range to your VPS, detailed here: https://support.cloudflare.com/hc/en-us/articles/200170786-Restoring-original-visitor-IPs
You can find IP range here: https://www.cloudflare.com/ips/
Sencond, whitelist your server IP at Cloudflare. Tutorial here: https://support.cloudflare.com/hc/en-us/articles/217074967-Configuring-IP-Access-Rules

Then check if problem resolved

P/S: One more thing,did you try to use other browser, and is it work? This problem sometime happen on Firefox but it work on Chrome or Edge and vice versa.

Hello, none of this helped me.
Still getting the same error.

Can you check if you have disk space on your hosting/server?

Does something change if you temporary switch from :orange: to :grey: (DNS-only) your DNS records or if you temporary enable the option “Pause Cloudflare for this site”?

Do you use any compression at your origin host / server?

Is the HTTP/2 option enabled at Cloudflare dashboard?

PHP? Nginx/Apache? Traffic maybe?

nginx.
i got a quircs error.

Could you please show us error and console error too?

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.