Hi there,

I’m experiencing an issue with my site simonpeterconstruction dot com
google domain
swipe pages hosted
Cloudflare redirects to naked domain

however - the site just stopped working today and says my certificate expired 40 days ago. how do i fix that?

Thank you


Thank you for asking.

I am sorry to hear you’re experiencing an issue here.

I can see you’re using BunnyCDN and it’s SSL certificate expired 40 days ago :thinking:

You could renew it by follow below steps:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS without any error
  4. Check with your hosting provider / Bunny CDN / cPanel AutoSSL / Let’s Encrypt / Certbot / ACME and renew it in case if needed
  5. Only then, when your website responds over HTTPS, you should un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Thank you @fritex

I’ll try what you suggest - although I don’t know what bunny cdn is at all.
I bought the domain on google.
built the landing page on swipe pages
signed up with cloudlfare to redirect the full www web address to naked domain - no idea what bunny cdn is

I’ll update here when / if this corrected :grimacing:

@fritex - still experiencing the error even after pausing for 10 minutes.

still don’t understand bunny cdn involvement

The root domain (ie without www) is being forwarded to a Google Maps listing for “Simon Peter Construction”.

The URL with www initially shows a security warning due to the expired Let’s Encrypt SSL certificate (expired February 1st, 2023). When I ignore the warning and continue, I see a website matching the domain name.

-1) Both www and non-www should go to the same place, ideally the website. You need to fix this in your Cloudflare dashboard.

-2a) Recommended: Renew your SSL certificate at your host. Then enable Cloudflare proxy again, and set your SSL/TLS setting to “Strict”.

-2b) If, for whatever reason, you’re unable to renew your SSL certificate (I don’t see why not, basic domain-authenticated certificates are free these days!), then enable Cloudflare proxy, but set your SSL/TLS setting to “Full”.

Good luck!

1 Like

You are absolutely right, but because of that very reason Full is never a good idea (as it provides no security) and I’d go with @fritex’s suggestion to make sure Full Strict is selected, otherwise the site would be insecure of course.

1 Like