Net:err_cert_authority_invalid

Hello,

I have this error ERR_CERT_AUTHORITY_INVALID on my domain campsabros.com.

Can you please help me solve this issue?

I already read topics that are similar to this issue and tried the suggested solutions from those topics but it still not working.

I used the Cloudflare Origin Certifiate and followed the instructions.
My SSL/TLS encryption mode is Full (strict).

This is also my DNS Records

Hi @droymanz ,

Hope you are doing great !

I can’t see any error on the domain . could you re-confirm from your side ?

Anyways Here’s a Community Tip about it !

1 Like

Do you have a local DNS resolver like pihole and create a DNS record there for your domain that points directly to a local resource? I got this error message when I switched to Origin certificates and had to remove the local DNS records to get it working again.

It is still the same on my end. See screenshot below

Unfortunately no. Can you recommend any FREE local DNS resolver?

I got the problem WHEN I was using a local DNS resolver, which overwrote the DNS to a local ip address :slight_smile:

Example:

www.example.de → overwritten to 192.168.80.2 (my proxy with origin certs) → Not working
www.example.de → 188.114.96.7 (just a example of a public ip addresss of Cloudflare proxy) → my proxy (origin certs) Working

Btw, you can test if this is your problem:
nslookup www.example.de → will ask your local dns server
nslookup www.example.de 1.1.1.1 → will ask the Cloudflare dns server

But I can recommend PiHole as a local DNS resolver

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.