Need twitterbot to NOT redirect

Twitterbot will not allow images on a shared https to be shown on their twitter cards, which means cloudflare SSL won’t work. To bypass this i setup a folder called /social/ and put og:image images in there. My cloudflare page rules are in this order:
mysite.com/social/ - Disable security
mysite.com/* - Always Use HTTPS
www#mysite#com/* - Always Use HTTPS (pretend the # are dots because this forum won’t allow 3 links facepalm).
Twitter card validator refuses to show the image because it’s still grabbing https. When I enter the direct path to the image in the /social/ directory it’s not redirecting to https, which is right. The image is staying as http and the padlock is not showing. Yet twitter card validator is won’t show it. Not even if I clear the cache or use ?utm_source=123 after the link. What am I doing wrong?

If you remove the Always use HTTPS rules does it make a difference?

No difference.

Please, I’ve been trying to do this for days, nothing has worked. Twitter cards won’t allow https from a shared SSL including cloudflare. The workaround mentioned is to create an .htaccess file and add code to not redirect twitterbot. The problem is this is breaking my pages saying there are too many redirects. I tried putting the twitter card image in a directory called /social/ and putting this page rule in cloudflare: my.com/social/ - Disable Security as the first rule, with no .htaccess codes and this simply is ignored by twitterbot even though if i manually put the path to the image in that directory it’s correctly not redirecting to https. PLEASE, I can’t be the first person to come across this compatibility issue with cloudflare SSL and twitterbot. There’s no info anywhere on what to do. If anyone can advise you’ll be the champion of all champions!

Hi @frank1,

I had already seen your another topic;

Could you please share a link from the official Twitter documentation pointing to this issue?

I don’t see any issues with Twitter Cards in general in terms of HTTP/HTTPS, as long as your certificate validates (shared certificates do) and as long as you don’t have mixed content.

If turning off the option to force HTTPS doesn’t help then whitelisting certain directories won’t be a factor, the issue is likely elsewhere.

Fixed it. Adding the directory with Security Disabled worked, but I was just missing the og:image:width and og:image:height attributes. Added those and the image showed up on Twitter Card Validator. Thanks.

This topic was automatically closed after 30 days. New replies are no longer allowed.