Need to delete AAAA but not showing up on my DNS settings

Need to delete AAAA but not showing up on my DNS settings. Weebly manager found 4 of them and screenshot them to me, but he cannot delete them for me, and godaddy whom I own the website through cannot access them. How do I proceed to get them deleted and my website secure asap?

2 Likes

You likely don’t need to change this at all, when you use Cloudflare you will see Cloudflare’s IP addresses, Cloudflare proxies users to your server.

Are you encountering actual issues?

Thank you for responding! Here’s the issues I am bumping up against:
1.I made Cloudflare my nameserver through the steps and setup, yet I am not SSL secure yet.
2. I made changes to my site via weebly.com and when I went to publish it, the error message came up saying that my website wasn’t configured correctly.
3. I called them and they said that I needed to enable the SSL through their settings on their editor, but because of the AAAA DNS records that he found, thso eneed to be deleted first and my IP address updated on Cloudflare.
4.I called godaddy where I own the website name through, but they cannot access my DNS because it is now going through Cloudflare.
5. When I go to the DNS section on my Cloudflare there are no AAAA files showing, just A. The weebly guy sent me a screen shot of the 4 AAAA that he pulled up under my website.

Ah yes… weebly for some reason doesn’t support IPv6. I really wish they would fix that… you van turn it off here to verify and then turn it back on.

1 Like

so does that mean I cannot delete the AAAA records in DNS?
Also, does that mean that because I have Weebly that I will not be able to get SSL as long as Cloudflare is my routing DNS?

You can use the api call to disable IPv6 on Cloudflare for weebly to issue the cert. You could also temporarily :grey: the record as well in the DNS settings I believe.

I had this same and was just able to fix this. Wanted to share the solution:

  1. In your CloudFlare dashboard, click on DNS and disable “Proxied” on all the Weebly IPs (so that it only shows “DNS-only”)
  2. Go to your Weebly dashboard, click on “Settings” from the top menu and “Enable” SLL
  3. This will finally allow you to enable the SSL without the “Remove AAAA record” error. Simply Publish the website again in Weebly.
  4. Under the “SSL/TLS” tab in CloudFlare, make sure that “Full” is selected.
  5. Re-enable “Proxied” under the “DNS” tab in CloudFlare for your website

That’s it! You should now be able to have full SSL on Weebly and CloudFlare, and IPv6 support.

Hope this helps!

9 Likes

Vladimir - Thank you VERY much for this advice. I followed your instructions and it worked… https://community.cloudflare.com/u/GetVladimir

2 Likes

Thank you so much, Joel!

I’m glad if it’s useful and good to know that it still works

2 Likes

This worked for me as well on July 29, 2020 … thank you!

1 Like

I solved by disabling and enabling again the Universal SSL under Edge Certificates because no Edge certificates were generated by Cloudflare. Encryption mode full strict (Let’s encrypt on origin)