Need SSH using domainURL alongwith the proxied feature

Dear Cloudflare Community,

I have activated my domain on Cloudflare and enabled the proxied feature so that my exact server IP doesn’t get exposed but when I do the SSH to my server using ssh [email protected] it is not working. It only works by disabling the proxied feature to DNS only. Why so???

Here’s my situation:

  1. I have written all the scripts that utilises only the domain URL for SSH.
  2. I want to do SSH to my server using ssh [email protected] while using the proxied feature.
  3. I don’t want to use the tunneling feature as it is not compatible with my scenario.

Any suggestions??
A quick response would be appreciated. Thanks!!

The Cloudflare proxy is only for HTTP/HTTPS traffic by default. If you want to proxy SSH, you need to use Cloudflare Spectrum…

Is it possible to achieve the solution I wanted??

If you want to proxy SSH using Cloudflare, then Cloudflare Spectrum is your only option. Click the link I posted for details.

Hii Cloudflare community,

I tried the feature Cloudflare Spectrum but it is not responding as per given steps. I performed the following steps:

  1. I navigated to Spectrum panel on the dashboard
  2. I had no any spectrum applications existing before
  3. I selected the “SSH” option and chose “create an application” in spectrum
  4. I added my domain (which is already having A record type and is proxied in the DNS records)
  5. I added IP address for the domain added above

But when I tried to save my configuration, it is showing the error:
A record already exists with that host (code 6)”

Quick responses will be appreciated!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.