Need help with SSL

Hi guys I have let my SSL cert expire via GoDaddy and decided to use the free version over here at Cloudflare.

I have pointed the name servers to cloudflares and I have received an email letting me know that all is setup and active, but I still don’t have a padlock.

Here is the domain

https://miltonupvc.co.uk/

Thank you all in advance

What exactly do you mean by that? You got an origin certificate from Cloudflare and configured that one instead of your previous certificate or you dont have any certificate at all now?

Hi thank you for replying. I originally had a ssl from Godaddy but I didnt want to pay for a new one, so I decided to get a free one from cloudflare.

Well, but you dont seem to have got one from Cloudflare (apart from the proxy certificates which are a completely different story) as you only have an expired certificate on your server.

If you dont want to renew the existing one you will need to get an origin certificate from Cloudflare and install that one on your server instead.

Ahh ok how do I do that?

Hi thank you for your help. I have followed the instructions you have provided and all seems good, but I still dont have a padlock.

Sorry for the poor image quality

Yes, your origin certificate seems to be in place all right now.

Can you post a screenshot of the error you get? For me it works just fine at this point

image

Also, make sure your SSL mode on Cloudflare is “Full strict”, now that you have a valid certificate again.

I am not getting an error, It just shows not secure in the www. box

Well, there seems to be a redirect. You also get the same message when going to https://miltonupvc.co.uk?

Yes I get this

Ohhh, that!

That is most likely because of DNS propagation. If you wait a couple of hours it should get automatically fixed.

Brilliant thank you so much for your help. its very much appreciated.

You can easily verify it.

Does

ping miltonupvc.co.uk

return a 104 address or not? As long as it does not, you are not going through Cloudflare but - presumably - to your server directly.

Yes my ping returns a 104

Then you shouldnt get that error. Can you clear your browser’s cache and restart it?

I have just cleared the cache, but still no luck.

But that is now a completely different error from the one before.

Can you try a different browser, e.g. Firefox? Unfortunately it is quite difficult to debug anything with all these Chrome-ish browsers as they hide half the information (e.g. whether you are on HTTPS).

still the same in Firefox. my dad has just tested it on his macbook using safai and it works fine.

Does it work on your end?