Need help with MX Mail Records settings

I set up the IP address for the new hosting company but the mail is not going through. I need someone to check my settings to make sure I did it right.

If we should have a chance at doing that, -

Could you please share your settings, including the MX record(s), and eventual other record(s) you have retrieved from your mail provider?

1 Like

Disable the Proxy status for the A record named mail.

1 Like

I am sending a test email from inside the godaddy mail to my other email address and still does not go through. Does this take time to propagate? I went to “whatsmydns” for the CNAME Record and its all Red “X’s”.

You do not have a CNAME record for the naked domain, but an A record, as such, querying the naked domain for the CNAME type will fail.

Switch the query type to A instead, and it will return Cloudflare addresses, since it is Proxied (:orange:).

If you wish to test the how the CNAME type appears, you need to add www. before the domain, so you’re checking the www record you have.

I am not sure if this is correct setting.

Dark Devil, Is there anyway I can message you directly?

On the Cloudflare Community, it won’t be possible (right now), as it would require TL3 (Trust Level 3) or higher to be able to send private messages.

Can’t guarantee any SLA (Service Level Agreement) though, neither here, or privately, … but:

Email, or Discord would perhaps be the best options for me, these days.

As emails aren’t getting through, according to this thread, that may be a wrong option to try? :thinking:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.