Need help with DNS

I have no idea of how to do that. I guess I’ll just have to cancel my Cloudflare account and get everything back to Ionos. I have no idea what to do next and it’s not easy to get hold of Cloudflare support, Ionos, I can just ring them. Thanks for your help anyway.

Do you not know where your web hosting is located at all was it with Ionos as well?

It was yeah, I had an email from Ionos earlier, saying I had to add my domain as a sub domain, I done that and just logged back into my Ionos account and my DNS settings were back, so I added them as a record to my DNS settings on Cloudflare which got rid of a few error messages. I tried my website again, still not working, and I have these two steps to do:

Use wizard to add an SPF record and define what mail servers are allowed to send mail for your domain.New Alert

Add an A, AAAA, or CNAME record for www so that www.djalkemy.co.uk will resolve. (I thought I added them already, it seems like this message appeared twice, one has disappeared, but this one still remains lol)

Your DNSSEC is broken. If you turn it off at your domain registrar, that should help fix the problem.

https://dnsviz.net/d/djalkemy.co.uk/dnssec/

Here are other threads with similar issues:
https://community.cloudflare.com/search?q=dnssec%20broken%20order:latest

1 Like

Cloudflare is now my registrar. When I clicked the DNS tab, then scrolled down to the DNSSEC section, it had this:

DNSSEC is pending while we automatically add the DS record on your domain.

That’s been like that for a couple of days, so I canceled it, then clicked it again, as my DNS settings weren’t right when I first tried it.

Hopefully, this will fix the issue.

Was it your registrar this morning? I’m pretty sure it wasn’t, so switching registrars while DNSSEC is enabled probably isn’t going to clear it up.

I’m not sure how to proceed. I left it a while, now when I click the website address I get this

I have no idea what any of that means sorry. I think I’m just gonna close the Cloudflare account down. I had everything running perfect on Ionos, and I could get through to them in a few minutes via phone. I could kill my friend for changing everything up, my website been down for over a week now.

We are slowly getting there by the looks of it.

That’s easily fixed if you already have an a record for djalkemy.co.uk just create a CNAME for www with the target to djalkemy.co.uk

Should look like this Screen Shot 2022-04-05 at 10.22.58 am

I’ll be completely honest provide a screenshot of everything you’ve got set up in the DNS tab in Cloudflare so we can get a better look at where you’re actually at.

It’s pretty serious that means regardless what you add to the DNS zone for your domain it ain’t going to be working until you resolve this issue the DNSSEC issue is one that really does need to be resolved.

Unfortunately you’ve gone from a semi managed service to a self service option. One that expects you to understand the basics of hard DNS works.

Does your friend not have the ability to answer the technical questions in here? or no what’s going on?

My friend has gone away for a few weeks, and to be honest, I don’t wanna be bugging him every twist and turn. And to be fair to him, it was running fine until I had to try and get an SSL certificate, to present to my bank. Anyway, that’s a long story lol.

So, here’s a screenshot of what my DNS settings look like in Cloudflare:

I’m wondering if it’s okay to give a screenshot of what they look like in Ionos, as there are:

CNAME: 2 of these entries (mail and domain connect), neither have www as an entry (I have the mail entry copied into my Cloudflare DNS settings (is that where part of the problem lies?)

MX: 2 entries (both identical, both mail)

A: 2 entries, both identical, both webhosting

AAAA: 2 entries. both webhosting, identical values, but, under the host name value, one has “@” and the other has “www”

TXT: One entry, has “@” as host name, and service is listed as “X-domain”.

Hope some of that helps you. I didn’t amend anything in my Ionos DNS settings, so the values in there are what Ionos did (just in case you were wondering if I’d messed with things manually)

Cheers.

I have no idea what to do next and it’s not easy to get hold of Cloudflare support, Ionos, I can just ring them. Thanks for your help anyway...

Your DNS records are probably fine (except for the missing ‘www’ record).

But your DNSSEC is still broken. Please open a ticket, either via the dashboard or mail to support AT cloudflare DOT com, and post the ticket # here so we can escalate it.

1 Like

Okay, I have emailed Cloudflare support to try and sort the DNSSEC issue. And shall I add the missing www record as stated above:

name: www
target: djalkemy.co.uk

Yes you should definitely add that record as I stated above.

However I think that IP is going to be for your previous domain names registrars parking pages.

I contacted Cloudflare support, but I’m on the free plan, so they sent me back here lol. I think what you said, in that Cloudflare is for people who have a handle on what they are doing, so I’m gonna try and go back to Ionos ASAP. Thanks for all your help guys.

You need to post your ticket ID here so it can be escalated.

1 Like

#2417129

So, the DNSSEC issue is now resolved, just this 525 issue left now and hopefully I can get this website back up and running.

This was the email I got from support:

Hi there,

Our registrar has cleared the DS records for you, and now your domain passes the DNSSEC test at djalkemy.co.uk | DNSViz

I’ll mark this ticket as Solved for the DNSSEC issue.

Moving on to the 525 error you were seeing, I see no SSL certificate on the server:

# openssl s_client -connect 217.160.0.115:443 -servername djalkemy.co.uk
CONNECTED(00000003)
139917294458176:error:14094438:SSL routines:ssl3_read_bytes:tlsv1 alert internal error:../ssl/record/rec_layer_s3.c:1543:SSL alert number 80
---
no peer certificate available
---
No client certificate CA names sent
---
SSL handshake has read 7 bytes and written 306 bytes
Verification: OK
---
New, (NONE), Cipher is (NONE)
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
Early data was not sent
Verify return code: 0 (ok)

This is not uncommon, so feel free to continue the discussion in the Community if you need more assistance with the 525 error.


I ran a diognostic test, and now all but one of my issues are solved. This is the one that I’m still stuck on:

Pic: Error-1 — ImgBB

Any idea guys?

This thread may aswell be closed, I’ve moved everything back to Ionos.