Need help with DNS

I recently transferred my website domain to Cloudflare from Ionos, but now my website is not loading.

When I log in to my Cloudflare account, and click DNS, I get the following:

A few more steps are required to complete your setup.

Add an A, AAAA, or CNAME record for www so that www.djalkemy.co.uk will resolve.

Add an A, AAAA, or CNAME record for your root domain so that djalkemy.co.uk will resolve.

Add an MX record for your root domain so that mail can reach @djalkemy.co.uk addresses or set up restrictive SPF, DKIM, and DMARC records to prevent email spoofing.


These all had an “error found” tab

I ran a diagnostic test from the following link (Diagnostic Center | Check SSL and Test Website Security | Cloudflare) and I get a bunch of errors:

Check DNS

Is there an A or AAAA DNS record to make connecting to ‘domain.com’ possible?SEC configuration

Check if connecting to ‘domain.com’ works

Is there an A or AAAA DNS record to make connecting to ‘domain.com’ possible?

Check if connecting to ‘www.domain.com’ works

Is there an A or AAAA DNS record to make connecting to ‘www.domain.com’ possible?

Check for existing MX records

Does the domain have an MX record?

These all had a “request failed” tab

Check for redirect loops

Does the request result in a redirect loop?

Check the HTTPS status

Does the site respond with a succesful HTTPS status?

Check if redirecting unencrypted HTTP traffic works

Does the website redirect unencrypted traffic from HTTP to HTTPS?

Check the status of encrypted traffic

How well does the website support encryption via an SSL/TLS certificate?

Check the site for mixed content

Does the website mix encrypted and non-encrypted content?

Check site speed (TTFB)

How fast is the page response time?


My website was running perfect a week or so ago, but I was requested, by my bank, to produce an SSL certificate, so I contacted Ionos, and the support I received had my changing all manner of options and settings, which stopped my website working, then they told me it was to do with Cloudflare. Anyway, long story short, I’ve now transferred my domain to Cloudflare, and would love to get the website back up and running ASAP.

Any help is greatly appreciated.

1 Like

Because you’ve transferred your domain name to Cloudflare Registrar you’re only permitted to use Cloudflare name servers.

Which means you now have to configure your DNS manually and add all relevant records to point to your web hosting into Cloudflare DNS tab.

What type of web hosting do you currently have?

Could you let me know how to that please.

I have no idea lol. A friend set up most of my website. Is there a way to find that out?

As you’ve been unable to sufficiently tell me enough about the host this is not a Cloudflare related issue you should contact your host and ask them to provide you all relevant records for a manual DNS setup.

Once you have all the relevant records provided to you by the host you should be able to enter them into the dashboard for the domain name in Cloudflare by going to the DNS tab.

Alternatively if you have a control panel notably cPanel they’ll be a way for you to see all records for the domain name and you can copy the relevant records to Cloudflare.

For cPanel you would log into your cPanel account and go to the Domain section then look for the menu Zone Editor and then you want to click the manage button next to the domain name in question and all the records for the domain name will be shown.

You can copy all relevant records to Cloudflare at this point and wait for propagation and your website and email and then the other services that you copied the relevant records for will start working again.

I’ve just spoken to Ionos and they’ve told me that Cloudflare have full control of my DNS settings seeing as they are hosting my domain. I have logged into my Ionos account and clicked on my DNS tab but it is totally blank. I’m not sure what else to do next. What a mess lol.

Is there not a Cloudflare support number in the UK?

It doesn’t matter it’s not a Cloudflare issue. You’re now responsible for managing and pointing the DNS to wherever it needs to go by adding it to Cloudflare.

I’m guessing what was happening before you were using the name servers for your web hosting provider which means they handled everything for you now you’re responsible for managing your own DNS Zone.

I have no idea of how to do that. I guess I’ll just have to cancel my Cloudflare account and get everything back to Ionos. I have no idea what to do next and it’s not easy to get hold of Cloudflare support, Ionos, I can just ring them. Thanks for your help anyway.

Do you not know where your web hosting is located at all was it with Ionos as well?

It was yeah, I had an email from Ionos earlier, saying I had to add my domain as a sub domain, I done that and just logged back into my Ionos account and my DNS settings were back, so I added them as a record to my DNS settings on Cloudflare which got rid of a few error messages. I tried my website again, still not working, and I have these two steps to do:

Use wizard to add an SPF record and define what mail servers are allowed to send mail for your domain.New Alert

Add an A, AAAA, or CNAME record for www so that www.djalkemy.co.uk will resolve. (I thought I added them already, it seems like this message appeared twice, one has disappeared, but this one still remains lol)

Your DNSSEC is broken. If you turn it off at your domain registrar, that should help fix the problem.

https://dnsviz.net/d/djalkemy.co.uk/dnssec/

Here are other threads with similar issues:
https://community.cloudflare.com/search?q=dnssec%20broken%20order:latest

1 Like

Cloudflare is now my registrar. When I clicked the DNS tab, then scrolled down to the DNSSEC section, it had this:

DNSSEC is pending while we automatically add the DS record on your domain.

That’s been like that for a couple of days, so I canceled it, then clicked it again, as my DNS settings weren’t right when I first tried it.

Hopefully, this will fix the issue.

Was it your registrar this morning? I’m pretty sure it wasn’t, so switching registrars while DNSSEC is enabled probably isn’t going to clear it up.

I’m not sure how to proceed. I left it a while, now when I click the website address I get this

I have no idea what any of that means sorry. I think I’m just gonna close the Cloudflare account down. I had everything running perfect on Ionos, and I could get through to them in a few minutes via phone. I could kill my friend for changing everything up, my website been down for over a week now.

We are slowly getting there by the looks of it.

That’s easily fixed if you already have an a record for djalkemy.co.uk just create a CNAME for www with the target to djalkemy.co.uk

Should look like this Screen Shot 2022-04-05 at 10.22.58 am

I’ll be completely honest provide a screenshot of everything you’ve got set up in the DNS tab in Cloudflare so we can get a better look at where you’re actually at.

It’s pretty serious that means regardless what you add to the DNS zone for your domain it ain’t going to be working until you resolve this issue the DNSSEC issue is one that really does need to be resolved.

Unfortunately you’ve gone from a semi managed service to a self service option. One that expects you to understand the basics of hard DNS works.

Does your friend not have the ability to answer the technical questions in here? or no what’s going on?

My friend has gone away for a few weeks, and to be honest, I don’t wanna be bugging him every twist and turn. And to be fair to him, it was running fine until I had to try and get an SSL certificate, to present to my bank. Anyway, that’s a long story lol.

So, here’s a screenshot of what my DNS settings look like in Cloudflare:

I’m wondering if it’s okay to give a screenshot of what they look like in Ionos, as there are:

CNAME: 2 of these entries (mail and domain connect), neither have www as an entry (I have the mail entry copied into my Cloudflare DNS settings (is that where part of the problem lies?)

MX: 2 entries (both identical, both mail)

A: 2 entries, both identical, both webhosting

AAAA: 2 entries. both webhosting, identical values, but, under the host name value, one has “@” and the other has “www”

TXT: One entry, has “@” as host name, and service is listed as “X-domain”.

Hope some of that helps you. I didn’t amend anything in my Ionos DNS settings, so the values in there are what Ionos did (just in case you were wondering if I’d messed with things manually)

Cheers.

I have no idea what to do next and it’s not easy to get hold of Cloudflare support, Ionos, I can just ring them. Thanks for your help anyway...

Your DNS records are probably fine (except for the missing ‘www’ record).

But your DNSSEC is still broken. Please open a ticket, either via the dashboard or mail to support AT cloudflare DOT com, and post the ticket # here so we can escalate it.

1 Like

Okay, I have emailed Cloudflare support to try and sort the DNSSEC issue. And shall I add the missing www record as stated above:

name: www
target: djalkemy.co.uk