Need help to insert Cloudfare DNS in my modem / Router


#1

Hi, I’m here today for ask you guys, where I put the DNS in my router and my modem

I want to know if I put in DHCP Server or in the Network.

I take some screenshot from my modem TD-W9970 and my router TL-WR849N, so you guys can guide me, and also I want to ask if you guys recommend to put the DNS in the router,modem and also in the computer

Here’s the link for the screenshots - https://drive.google.com/open?id=1z0qGkyPnn3zo2u1zWtvW334AE7PzANHq


#2

I would recommend setting it only at the modem/router level and then leave the router’s IP for the local computers to improve the speed and caching.

You should probably remove the double WAN, if possible. The second router (with the 192.168.x.x IP) that is not performing the PPPoE connection should be simply used for Wi-Fi or as a switch, without reissuing it’s own IPs. This is what it’s called a double NAT, that creates all sorts of problems and should be ideally avoided unless strictly necessary. Put this router only on switch/AP mode, it should be straightforward.


#3

So I put the DNS only in the PPPoE network, and let the DHCP Server without any DNS and in the second router just set the DNS to the Wi-Fi


#4

I don’t completely get this: did you set Cloudflare’s DNS only in the Wi-Fi settings? How did you do that?!


#5

I use my modem TD-W9970 (for ethernet and is PPPoE connection) and my router TL-WR849N (for Wi-Fi), but I insert the Cloudfare DNS in the DHCP not in the WAN Network settings and in the Modem PPPoE connection I do the same just insert in the DHCP settings.Did you recommend do this or just put dns in PPPoE settings and also in the WAN settings


#6

Only in the PPPoE settings. All other settings are useless and redundant (they should all point to their DHCP server).

Follow this guide on your TL-WR849N to remove it’s WAN settings and use it only as an access point which will remove the need for an additional DHCP server giving all of it’s duties to the main router (the one with the PPPoE connection).

https://www.tp-link.com/us/faq-641.html


#7

thank you matteo


#8

This topic was automatically closed after 14 days. New replies are no longer allowed.