Need Help Setting Up All My DNS Settings Correctly

I searched for the correct way to setup all of my DNS settings and can’t seem to get them all set up correctly. I looked at my hosting company’s DNS records but I tried to copy them into Cloudflare and somehow couldn’t get them set up correctly.

Do I need to add or edit any settings on Cloudflare? And/or on my cpanel on my hosting company?

Why not?

Yes, you do.

All DNS records need to be present on Cloudflare. It would appear as if most of them were imported anyhow. What is missing?

Thank you @sandro for your help so far!

I tried to add all the settings from my cpanel to cloudflare but I couldn’t move on TXT record.

I am having trouble setting up _cpanel-dcv-test-record.seanstestingsite.site with the text in cloudflare. Is this a valid record or do I need to delete it?

Do I need to add a www.seanstestingsite.site record and point to seanstestingsite.site? Because I did that and tried to add that record and cloudflare said I already had that record.

How do I setup localhost to DNS only - local IP for my other domains?

And, how do I setup the MX and TXT records to DNS only for my other domains?

Looks like a regular record. Just add a TXT record with the respective values.

Well, that already got added.

That localhost record is already unproxied, however I’d question why you need the whole record to begin with.

I am getting these errors so far in trying to add that TXT record. Is there something that I am doing wrong?

The name is not really correct. Remove everything after the first dot (including the dot).

I removed the underscores before and after, and I removed the dot after and I am still getting the same errors such as already have a record, and of course DNS Validation Error.


After which dot? There were no dots. Those were underscores. It is very, very hard to see that because the image was so small.

And, what do you mean, as far as remove everything? I am not getting you, sorry.

I count three dots in your screenshots.

Post a new screenshot with the changes you made.

Plus there likely is a whitespace at the end.

This is the code I shared on the screenshot with nothing changed as you suggested because there is no dots. There was not a blank space after I clicked save also. Do I really need this record anyway, I wonder?

cpanel-dcv-test-record=O3DmarX7X_w3EQksAFOoB_XK3Rocs4a5czem_rEOWM9A5xvonfN04xJrtC7Gc6Q

Ehm, thats the content, not the name.

Also, I assume you should remove everything up to = in the content field.

Here’s the name without any edits:

_cpanel-dcv-test-record.seanstestingsite.site

There is only one dot there. I will remove that, and try it again, and then see what happens then.

Do I really need this record though?

I tried even removing that dot but I still got the same DNS validation error.

I"m just going to delete that record and try using my site, however, if you think it is essential to try to get working I will try to get it working and go from there. I apologize for all of the back and forth we had. I do really appreciate you trying to help me with getting this DNS record straight.

There are two dots in that FQDN. But I assume you have tried _cpanel-dcv-test-record by now and made sure there is no whitespace anywhere whatsoever, right?

As for the record, that seems to be something Cpanel related. I am afraid I cant tell you whether you need it for that, however you wont need it for Cloudflare.

That record is used by cPanel during SSL certificate issuance (for validation). It depends if you are using cPanel SSL or something like Let’s Encrypt or a Cloudflare Origin Cert.

Yes, your right. There were two dots in the name of the record. I was stuck on thinking that you were talking about the record itself. I apologize for arguing with you. You’re the expert in this, and I’m not. I appreciate greatly again for your help.

Do you know if it would be best to use Let’s Encrypt or cpanel for an SSL certificate?