Need help finding a redirect

Hi, I have an old redirect somewhere in our Cloudflare set up that I cannot locate. I have no enabled Rules on the domain at this time. Also, I’ve downloaded and double checked the DNS CNAME records and can find no reason why this is happening.

When I run a curl using the -iL options, I can see the 301 redirect coming from Cloudflare. However, again, I cannot locate this rule anywhere in our set up for this domain records or in the ‘Rules’ page redirect stuff provided by Cloudflare.

What am I missing? Where else could this be happening?

If you’re proxied by Cloudflare, pretty much all redirects will look like they’re coming from Cloudflare. Only if you’re lucky will your server put a clue in the header as to what injected the redirect.

For your ‘curl’ command, I suggest you try it against the origin with a --connect-to :: parameter. But with your server’s actual IP address.

There’s also a very outside chance you have a Workers Route set up that’s doing this.

Thanks @sdayman !!! I did actually find a worker route that appeared to be a problem. However, after deleting it I’m now getting a 503 from Cloudflare on the hostname I’m trying to resolve instead of a redirect.

Again, CNAME looks good so I’m wondering if this is some caching issue. Hopefully it will begin working.

1 Like

Hey, could use some help/advice. I’ve run into a pretty nasty redirection issue on one of my CNAME entries that I cannot debug further on my own. I need help from an engineer at Cloudflare. However, I cannot update my billing plan in the Dashboard (to get a plan with support) even tho I have a SuperAdministrator account. I believe this is a bug in the Dashboard but again, I can’t get support with a Free plan account so I’m kinda stuck.

Really don’t want to change providers. Is there any way to get help?

Post the issue here, and we can escalate to an engineer in the Community.

1 Like

That’s typically Rate Limiting.

If it’s still not working, post the URL, we can take a look.

Thanks @sdayman. The issue is on I’m attaching a screenshot of the error as it appears in Chrome. I looked at the error 1016 which indicates that the underlying target of the CNAME record is unresolvable however it works fine for other hubspot host entries like www. In fact you can check it with the host command on the console

host is an alias for is an alias for has address

That same endpoint also serves up the static website which is working fine so it can’t be what the error indicates.

Thanks for any help

It seems to me that you need to get Hubspot to add your hostname to their CNAME list. In other words, they’re on Cloudflare, but they don’t have their end configured to recognize your CNAME.

It’s like trying to get a web server to respond to an alias hostname it’s not set up for.

Hey @sdayman the DNS set up in Hubspot appears to be correct. Just to be safe yesterday I deleted and re-added the DNS entry from the hubspot side and it says it’s resolving it from Hubspot (see attached for current status screenshot).

Is there anything specific you can see in the way this is set up from the Cloudflare side that could still be causing it to redirect? I pulled down the bind file yesterday and dug thru it but can’t see any reason it would still not be resolving.


I’m mobile right now, so I can’t do much digging around. As I see it, you have a DNS Only CNAME here and the origin is not properly configured. You’d have to raise this issue with the host, as all Cloudflare is doing for you is to provide a generic DNS record.

Hey no worries @sdayman! I appreciate the guidance and suggestions. I’ve also been working this from the hubspot side and just received an interesting update from them (so take with salt grains)

“Our Technical Support Team is currently working on troubleshooting this with Cloudfare. Currently has been blocked by Cloudfare and they are reviewing the reason for this block which will allow our team to debug the redirect issue further once this block is resolved.”

Sounds promising. Thanks again!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.