Navigation links stop working like the button and menu

after my site to Cloudflare, my website navigation links stop working like the button and menu

Thank you for writing.

May I ask you to post and share your domain name in bracketed dot [.] notation here and URL example to the particular resource with us so we could double-check, troubleshoot and provide some feedback information? :thinking:

Hm, without having any example URL or clue, I could try to troubleshoot what it could be.
Please, double-check the options at Cloudflare dashboard for your domain name as follows:

  1. SSL/TLS settings → Edge Certificates → HSTS feature and therefrom you might have got the X-Content-Type-Options=nosniff option checked (sometimes we do see some errors shown in the console of the Developer Tools (F12) in our Web browser that resources aren’t being loaded because of it)
  2. Speed → Optimization → therefrom it might be that the “Auto Minify” option for HTML, CSS and/or JavaScript is checked and enabled, causing some issues when updating your menu items, styling, etc.
    2.1. On the same tab, maybe the “Rocket Loader” feature is enabled and some script might be in a conflict which prevents proper functionality and loading of it, you can try to disable it
  3. Caching → Configuration → the “Browser Cache TTL” might be set to 4 Hours by default, try setting it to the “Respect Existing Headers”
  4. You might be using some Website builder, if any, like Elementor or some different if using WordPress?

At the end, navigate back to the Caching → Configuration click on the blue button saying “Purge Everything” to flush the cache at Cloudflare Edge, just in case.

Wait for a minute or two.

Refresh a page in your Web browser, otherwise try clearing your Web browser cache or use a different Web browser to test out again.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

I was checked my website and I don’t know how plugin was deleted on wordpress plugin section after troubleshooting I was reinstall plugin of Cloudflare and integrate global api and after all done purge every thing I checked my site it’s works all menu link and button works fine …

But I have one question is it required to install Cloudflare plugin on wordpress site. can we run website without plugin and without any problem like I told before…

I’d say it’s not necessary to install it, rather it’s optional, especially if you’re more comfortable and used to Cloudflare dashboard :slight_smile:

However, there is also the official Cloudflare APO for WordPress plugin which offers some other different settings related to the cache, and more oriented so it’s useful and a required to have it installed, if that’s to concern.


Furthermore, may I ask if we’re talking here about The official Cloudflare for WordPress plugin or the Cloudflare APO for WordPress? (2 different things) :thinking:

Yes, sure.

But till I was not using Cloudflare plugin all buttons and menu links are not working…
And when I was installed this and configure all menu and button works fine is it any possibility due to plugin this type of problem occurs

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.