Nameservers updated, but I still can't link my site with cloudflare

As you can see in the screenshot, I’v already updated the nameserver but clodflare still asks me to update them. I’ve tried “Re-checking” several times, but it’s not working

May I ask the name of your domain?

It’s aabhusan.com.np

Okay, it’s definitely set up correctly on your registrar’s end as a dig @1.1.1.1 aabhusan.com.np revealed.


I wanted to ensure it was, as your CloudFlare dash shows. With that out of the way, and you’re likely eager to get going here (who isn’t when it comes to their sites?), I can only offer this advice: your Registrar is the issue. There is no way that CloudFlare is taking as long as you have been waiting (which I assume has been quite some time now) to take over as your DNS provider. Do this, if you’ve not already: (this may sound counter-productive) reset your DNS to that given by your Registrar. Wait a few minutes and then re-apply CloudFlare’s DNS servers. Or wait and see if you’d prefer. That’s about all you can do. My apologies that I’ve not an easy solution for you.

EDIT: My mistake. Your second nameserver is incorrect. See the screenshot.

SECOND EDIT: I was incorrect - that is a SOA record only.

Regards! :slightly_smiling_face:

Hey, thanks for the reply. May I know where you took that screenshot from? Cause my cloudflare dashboard shows both nameservers to be correct. Also, I used this tool and found the same result: https://whois.domaintools.com/aabhusan.com.np

I have tried updating it on registrar’s side but that didn’t help. What else do you think may be causing this problem?

I’m not thinking clearly yet today, forgive me. The records I gave were simply the SOA, so the second entry is not your set nameserver. It’s correct, as both your online query and that of https://dnschecker.org/all-dns-records-of-domain.php reveal. You’ve no A or AAAA records set, though. It’s been awhile, can you get into the DNS part of the CloudFlare Dash yet? If so, get those set up to point to your site.

No, it’s already been about 2 days and I still get the same problem. Tried rechecking many times. It was working previously on my other domain from the same registrar, idk whats the problem now

Someone with deeper access needs to help you. @sandro or @sdayman may have the answer.

Oh sure. And thanks a lot for looking into the problem. Stay safe dude

You too & I wish I could help you solve this ASAP…

1 Like

And since you mentioned @sandro and @sdayman, does that send them notification so that they could look into this problem? I’m new to this community and don’t know much :sweat_smile:

Yes. And if they cannot they’ll call in @cloonan , who I’ll not yet call in.

1 Like

Hi @aabhusanaryal,

There is a typo in one of the nameservers, it should be isaac.ns.cloudflare.com, not issac.ns.cloudflare.com. Double a, not double s - that did take me a minute to spot!

2 Likes

Thank-you @domjh. I missed that. Where’s the rest of my coffee??? :smiley:

2 Likes

Literally the #1 cause of downtime in DNS transfers in my experience. ‘Click to copy’ and a know-it-all pre-teen looking over your shoulder while you make the change are your only defenses.

2 Likes

Thanks a lot dude.

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.